locked
Power Plans RRS feed

  • Question

  • Hi, im trying to control the Display Brightness via GPO for Windows 7 but cant find a setting anywhere for it.

    Also, i need to enable hibernation to.

    Thanks

    Wednesday, May 25, 2011 7:53 PM

Answers

  • Managed to resolve the hibernate issue.

    I disabled Hybrid Sleep from Computer Configuration\Preferences\Control Panel Settings\Power Options BUT would NOT apply for some reason so i also set it here  "Computer Configuration\Policies\Administrative Templates\System\Power Management\Sleep Settings and this did work. No idea why !!!

    Out of interest, out of the two, preferences and polcies, which would win if they hit a conflict ?  (i know computer always win but im reffering to the two user settings)

     

    Friday, May 27, 2011 11:37 AM

All replies

  • To start with the bad news: Display brightness is not adjustable by GPO.

    Hibernation on the other hand has a few possibilities. They are located under Administrative templates/System/Power Management/Sleep Settings.

    These settings require hibernation to actually be available. To do so, distribute a script by the means of your choice with this command line:

    powercfg -h on

     

    Wednesday, May 25, 2011 8:10 PM
  • Thanks for your response.

    Not to worry about the brightness. I didnt think there was a setting to be honest.

    Hibernation - I did Enable it, also from research, i believe default behaviour is On anyway. However, my users dont have the hibernate option listed on there shutdown menu so i set "Hybrid Sleep" to off and bingo, my setting was there so off i went and set this at gpo level. Ran a report and i could see my policy had been processed from the client, but when i log on, the setting "hybrid sleep" was still set to On thus hibernation was not present from the shutdown menu !! ARRRRRHHHH

    Whats wrong ?

    Any ideas ?

    Wednesday, May 25, 2011 8:49 PM
  • If hybrid sleep is still on after turning it off with a GPO then the problem lies elsewhere... You should worry about why hybrid sleep is still on, not why hibernation isn't.
    Wednesday, May 25, 2011 10:25 PM
  • Display brightness can be controlled useing this polciy http://gps.cloudapp.net/Default.aspx?PolicyID=2170 and other similar settings. This is a native Group Policy Administrative template... You cannot set it via Group Policy Preferences as this options was not added to support the new feature in vista... :(

    Hope that helps...

     


    Alan Burchill (MVP)
    http://www.grouppolicy.biz
    Follow me on twitter @alanburchill
    • Proposed as answer by Alan Burchill Thursday, May 26, 2011 3:20 AM
    Thursday, May 26, 2011 3:20 AM
  • I already have this set. Its the brightness % which users see all day. The slider bar within power plans needs moving right up but cant be controlled from policy.
    Thursday, May 26, 2011 8:01 AM
  • Hi,

     

    As far as I know, display brightness cannot be controlled by group policy. According to your feedback, you have turned off Hybrid Sleep via GPO and the GPO was applied, but Hybrid Sleep was on and the hibernation option is not showed on Shutdown menu. Which group policy setting did you use to turn off Hybrid Sleep? Check the following:

     

    Computer Configuration\Policies\Administrative Templates\System\Power Management\Sleep Settings

    Or

    Computer Configuration or User Configuration\Preferences\Control Panel Settings\Power Options

     

    Did you make sure hibernation is enabled with the command “powercfg /hibernate on”. Please also run “powercfg /a” with administrator and paste the output here for research. In addition, run the following command with administrator on one problematic Windows 7 client:

     

    gpresult/v > C:\policy.txt

     

    Then, please paste the content of policy.txt here.

     

    Best Regards,

     

    Nina Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com.  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, May 27, 2011 9:17 AM
  • Managed to resolve the hibernate issue.

    I disabled Hybrid Sleep from Computer Configuration\Preferences\Control Panel Settings\Power Options BUT would NOT apply for some reason so i also set it here  "Computer Configuration\Policies\Administrative Templates\System\Power Management\Sleep Settings and this did work. No idea why !!!

    Out of interest, out of the two, preferences and polcies, which would win if they hit a conflict ?  (i know computer always win but im reffering to the two user settings)

     

    Friday, May 27, 2011 11:37 AM
  • Also, any reason why i dont have a Display Brightness Slide bar within the Power Plan options when i log onto the W7 client ?
    Friday, May 27, 2011 2:38 PM
  • Hi,

     

    I am glad to hear that the hibernate issue has been resolved. For your inquiry on conflicts between GPP and GPO settings, it depends. Please describe the settings in detail so that I can test it on my side.

     

    For the “Display Brightness Slide bar”, do you mean the bar which displays the current brightness after pressing relative button on the monitor? Does the issue only occur on Windows 7 clients? When did the issue begin to occur? Do you have the proper display card driver installed? Please provide us more information.

     

    Thanks.

    Nina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 31, 2011 9:15 AM
  • My device was on XP and i could change the display, now i have upgraded to W7, the display setting (slide bar) has gone. Not even available from within Windows Mobility Centre.

    Display drivers are not old either !

    Tuesday, May 31, 2011 2:19 PM
  • Hi,

     

    According to your description, the new issue is caused due to the compatibility side or the Windows 7 OS side, please submit a new thread on the Windows 7 forum to narrow down the root cause. Refer to:

     

    http://social.technet.microsoft.com/Forums/en-us/category/w7itpro  

     

    Thanks for your understanding.

     

    Best Regards,

    Nina


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, June 1, 2011 1:51 AM