none
Project Site's Tasks List not sync RRS feed

  • Question

  • Hello,

    It seems I am having an issue with Project Site's Tasks List as it doesn't sync with the Project Plan/Schedule in Project Online.

    In all of the instances, the setting in PWA Settings/Connected SharePoint Sites: "Sync Enterprise Projects tasks to Tasks List" is always checked.

    The thing is that it used to work fine: whenever I published a new project, whether it was "Automatically create a site on first publish" or "Allow users to choose", the Tasks Lists were successfully synced.

    Recently I have removed/deleted the existing connected project site and created a new one based on default Project Site templates, meaning the synchronizable lists (Risks, Issues, Tasks etc.) must remain. Now the sync problem occurred for both newly published projects and existing projects. The Project Site's Tasks List appeared empty although it was locked for edit in PWA. I though the sync would have run overnight, but it didn't.

    Does anyone have any clues about this and how it can be fixed?

    Thanks,

    Linh


    Thursday, April 30, 2015 12:10 PM

All replies

  • Hi,

    You need to go to the server settings, "connected SharePoint site", click on "settings" and activate the option below. This is by default disabled in order to optimize performance.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 30, 2015 12:12 PM
    Moderator
  • It was always activated. As I mentioned, it used to work fine until I removed the project site and connected to a new one.

    Thursday, April 30, 2015 12:16 PM
  • Did you try to synchronize the new site and see if it helps:


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 30, 2015 12:22 PM
    Moderator
  • Yes I did though I believe that this Synchronize function is only for users, permissions etc., not for the tasks as the Tasks List is still empty.
    Thursday, April 30, 2015 12:27 PM
  • my suspicion is that it is getting (or trying to) sync to a different tasks list, instead of the default one. 

    You can check this by looking under Server Settings >> Connected SharePoint Sites, under the columns Tasks List.

    This generally happens, if your custom template has a list named alphabetically higher than the 'Tasks' list. That list is automatically picked up. 


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Thursday, April 30, 2015 2:36 PM
    Moderator
  • I also noticed this issue once as it locked edit of another task list named "Actions". However this list was empty as well as the default "Tasks" one, maybe because Actions' fields/columns had been changed.

    I tried to sync again with a basic Project Site template which has only 1 task list as default. The problem still persists. No sync happened.

    Thursday, April 30, 2015 2:58 PM
  • Linh,

    What is the task list you see under the column Server Settings >> Connected SharePoint Sites, under the columns Tasks List, when you use the default template?

    More over, is this is a new project or an old project? I think there is an issue if yo turn off and turn the sync option again for existing projects. May be it applies to projects that you delete and recreate project site for?


    Cheers,

    Prasanna Adavi, Project MVP

    Blog:   Podcast:    Twitter:    LinkedIn:   

    Thursday, April 30, 2015 8:11 PM
    Moderator
  • When I used default template, the "Tasks" was picked up because there was no other task-type lists.

    In the previous instances, it was all the times "Tasks" which was picked up except of one as I mentioned about the list named "Actions" (also not sync). 

    Initially, the issue only happened with the old project when I removed the site and tried to reconnect with a recreated site. Now it seems happening with newly published project even.

    Yesterday I tried to turn off and on the sync option once again but nothing changed.

    Friday, May 1, 2015 6:57 AM
  • Linh:

    Microsoft recently changed the default behavior to not synchronize. Guillaume's first reply below this one highlights a new setting that did not previously exist in Project Online. Are you certain that you checked this?


    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Friday, May 8, 2015 11:26 AM
    Moderator
  • Hi Gary,

    As I said, the sync setting has been left 'Checked' as always, I am also aware of MS' recent changes. So I did deselect the sync setting, save & close, then open it again to re-select and save. But still nothing happened/synced.

    Few days ago, a Project Manager opened, edited and published his existing project (on Project Server) with creating project site. Guess what: it worked - the sync was successful.

    Having seen that, I tried to do it all again with both new and existing project. Still no sync happened.

    Is it maybe the issue with the account setting? I have 'Full Control' though.

    Sunday, May 10, 2015 8:28 PM
  • If you are certain that settings are correct, then I would consider opening a ticket with support through the tenant interface.

    Gary Chefetz, MCITP, MCP, MVP msProjectExperts
    Project and Project ServerFAQs
    Project Server Help BLOG

    Tuesday, May 12, 2015 4:49 PM
    Moderator