none
Robocopy can not ignore timestamps RRS feed

  • Question

  • Hi,

    trying to copy 2TB of files without touching the timestamps to a ReadyNAS NVX, but robocopy always adds option /COPY:T

    Running robocopy /MIR /COPY:DSO /R:0 /W:0 says in the header:

    Options : *.* /S /E /DCOPY:D /COPY:DTSO /PURGE /MIR /R:0 /W:0

    Windows Server is 2008 R2 and robocopy version June 2012.

    Even if I use /NOCOPY all files get touched by robocopy.

    It seems robocopy can not set the change date.

    But it might be a bug, that it's not possible to prevent robocopy from touching all timestamps.

    Any hints?

    $ stat Bericht\ GBE.doc
    File: `Bericht GBE.doc'
    Access: 2011-11-21 06:33:02.120628500 +0100
    Modify: 2007-06-13 12:53:49.479970900 +0200
    Change: 2012-08-15 09:00:19.820677500 +0200
    Birth: 2011-06-29 09:39:23.572725800 +0200

    File on NAS:

    $ stat Bericht\ GBE.doc
    File: `Bericht GBE.doc'
    Access: 2011-11-21 06:33:02.120628500 +0100
    Modify: 2007-06-13 12:53:49.479970900 +0200
    Change: 2007-06-13 12:53:49.479970900 +0200
    Birth: 2011-06-29 09:39:23.572725800 +0200

    Thanks in advance!

    Kind Regards,

    Nicole


    • Edited by Roxy78 Thursday, September 20, 2012 10:00 AM
    Thursday, September 20, 2012 10:00 AM

Answers

All replies

  • Hi,

    To copy all files from a folder to another folder with RoboCopy keeping the
    original timestamp:

    robocopy Source_Path_Here\*.* Destination_Path_Here\ /B /COPY:DATOU

    Regards,

    Yan Li


    Yan Li

    TechNet Community Support

    Monday, September 24, 2012 9:03 AM
    Moderator
  • Hi,

    with this options I get

    ERROR 1314 (0x00000522) Copying NTFS Security to Destination Directory \\x.x.x.x\backup\ A required privilege is not held by the client

    Thanks!

    Kind regards,

    Nicole

    Wednesday, September 26, 2012 8:51 AM
  • Hi,

    This is mostly related to a permission issue. Make sure that you have enough privileges to perform this action.

    http://answers.microsoft.com/en-us/windows/forum/windows_vista-security/error-0x80070522-a-required-privilege-is-not-held/78cc11ec-c543-418d-9183-131318e9db8a


    Regards,
    Rafic

    If you found this post helpful, please give it a "Helpful" vote.
    If it answered your question, remember to mark it as an "Answer".
    This posting is provided "AS IS" with no warranties and confers no rights! Always test ANY suggestion in a test environment before implementing!

    Wednesday, September 26, 2012 9:33 AM
  • This is beacuse your NAS file system does not support "ChangeTime" (and makes it equal to LastWriteTime or Modify), but Windows + NTFS does and have separate values.

    I've hit the same problem recently (http://stackoverflow.com/questions/27534448/how-do-i-get-change-file-time-in-windows).

    You can't make robocopy ignore ChangeTime. There are two potential workarounds:

    1. Use something other than robocopy to sync files.

    2. Reset ChangeTime to make it equal to LastWriteTime on Windows. (This won't be a perfect solution for regular operations since it's possible a change is generated in between running a script that resets it and robocopy).

    Thursday, December 18, 2014 12:24 AM