locked
Response Group Agent conditional call forwarding RRS feed

  • Question

  • Hi Everyone,

    I have setup Lync server 2013, and have set up the PSTN gateways to a VOIP provider. I am able to receive and make calls fine. I have set up a response group, and have added one agent to it. During working hours the agent can receive the calls on the Lync client. However when he steps out, he would like to easily set the call forward to his mobile and receive the incoming calls on that. This isn't working.

    If I disable the workflow, and have the external VOIP number assigned to that agent (as a Lync user), he is able to forward the calls to his mobile by setting up the call forward in his Lync client. However if he receives the call from the RG workflow, even if he sets the call forwarding on, the calls don't get forwarded, but continue to ring on his Lync client. Any help would be greatly appreciated.


    Ajey

    Tuesday, June 11, 2013 3:24 PM

Answers

  • This is expected behavior for calls routed through the RGS workflow. RGS calls do not follow call forwarding/simulring rules.
    • Proposed as answer by Lisa.zheng Wednesday, June 12, 2013 8:32 AM
    • Marked as answer by Lisa.zheng Wednesday, June 19, 2013 10:14 AM
    Tuesday, June 11, 2013 4:04 PM

All replies

  • Hi

    Type the telephone number in the format sip: + 1234567890@domain.com. it will forward to external number.

    How did you configure your response group.


    Whenever you see a helpful reply, click on Vote As Helpful & click on Mark As Answer if a post answers your question.

    Tuesday, June 11, 2013 3:34 PM
  • Type the telephone number in the format sip: + 1234567890@domain.com. it will forward to external number.

    How did you configure your response group.


     

    Hi

    Thanks for the quick response. Should I type the number to be forwarded to, as a SIP in the Lync Client?

    For the response group, I created a response group and added the user as an agent. I then created a queue based on the response group and then created the workflow, using this queue.

    Ajey


    • Edited by Ajey P Tuesday, June 11, 2013 3:41 PM
    Tuesday, June 11, 2013 3:38 PM
  • This is expected behavior for calls routed through the RGS workflow. RGS calls do not follow call forwarding/simulring rules.
    • Proposed as answer by Lisa.zheng Wednesday, June 12, 2013 8:32 AM
    • Marked as answer by Lisa.zheng Wednesday, June 19, 2013 10:14 AM
    Tuesday, June 11, 2013 4:04 PM
  • ok, Thanks.

    Is there an alternative to achieve this?


    Ajey

    Tuesday, June 11, 2013 4:25 PM
  • I tried assigning the telephone number in SIP format in the call forward part of Lync client, and the problem did not get resolved

    Ajey

    Tuesday, June 11, 2013 4:52 PM
  • Not with Response Groups.
    Tuesday, June 11, 2013 4:54 PM
  • The method mentioned by Raju_raju is not executed with Lync client. It is set in Lync Control Panel.

    You can choose Forward to telephone number when you select Enable queue time-out. Then if no agent accept the call, the call will be forward the telephone number you specified.

    http://technet.microsoft.com/en-us/library/jj205207.aspx

    But as Jamie post, the simultaneously ring for the agent won’t work, it is not supported.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, June 12, 2013 8:48 AM
  • Hi

    In the RGS work flow outside business hours Forward to number there you can specify the external number in the above format.

    Check this Thread

    http://social.technet.microsoft.com/Forums/en-US/ocsvoice/thread/2a742bf5-865f-4963-90fe-ca2fe245853a

    Creating RGS

    http://cruxlab.wordpress.com/2013/01/11/creating-a-rsg-response-group-in-lync-2010/

    http://knowledgectrl.wordpress.com/2012/11/02/lync-response-group-forwarding-to-cell-phones/ 


    Whenever you see a helpful reply, click on Vote As Helpful & click on Mark As Answer if a post answers your question.

    Wednesday, June 12, 2013 10:33 AM
  • Hi,

    Thanks again for the helpful response. One of the things I need is the ability for the agent to quickly set it to forward to his mobile when he is stepping out. The methods you mention above are for forwarding periodically (say a certain time period, that is, non-working hours). Also, I had tried these methods and they didn't work too.


    Ajey


    • Edited by Ajey P Wednesday, June 12, 2013 2:14 PM
    Wednesday, June 12, 2013 2:14 PM
  • Hi,

    thanks for your reply. As I have mentioned in my post, I really need for the agent to himself tell his lync client (or anything else) that he is stepping out, and the calls that he receives now, should get forwarded to his mobile. Another drawback in the method that you mention, is that the caller will have to wait for certain calls before the call gets forwarded. If the caller happens to be a prospective customer, he will drop the call, on not getting a response for some calls.


    Ajey

    Wednesday, June 12, 2013 2:17 PM
  • I think you can just enable the simultaneously ring for that person in Lync option. 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, June 17, 2013 11:12 AM