locked
how do i discover in local machine registry RRS feed

  • Question

  • i have wrote discovery managament pack which  discover the local application Service registry key

    Software\Service 

    but how do i tell that management pack to search the local computer itself on which it is imported

    here is my xml

    <?xml version="1.0" encoding="utf-8"?>
    <Configuration xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xsi:noNamespaceSchemaLocation="C:\Users\administrator.HEALTHCARE\AppData\Local\Temp\tmp64A2.tmp">
      <ComputerName>$Target/Property[Type='Windows!Microsoft.Windows.Computer']/NetworkName$</ComputerName>
      <RegistryAttributeDefinitions>
        <RegistryAttributeDefinition>
          <AttributeName>ServiceNameExists</AttributeName>
          <Path>SOFTWARE\SERVICE</Path>
          <PathType>0</PathType>
          <AttributeType>0</AttributeType>
        </RegistryAttributeDefinition>
        <RegistryAttributeDefinition>
          <AttributeName>ServiceName</AttributeName>
          <Path>SOFTWARE\SERVICE</Path>
          <PathType>1</PathType>
          <AttributeType>1</AttributeType>
        </RegistryAttributeDefinition>
      </RegistryAttributeDefinitions>
      <Frequency>600</Frequency>
      <ClassId>$MPElement[Name="Suresh.Computer.WebService"]$</ClassId>
      <InstanceSettings>
        <Settings>
          <Setting>
            <Name>$MPElemet[Name="Windows!Microsoft.Windows.Server.Computer"]/PrincipalName$</Name>
            <Value>$Target/Property[Type='Windows!Microsoft.Windows.Computer']/NetworkName$</Value>
          </Setting>
          <Setting>
            <Name>$MPElement[Name="System!System.Entity"]/DisplayName$</Name>
            <Value>$Target/Property[Type='Windows!Microsoft.Windows.Computer']/NetworkName$</Value>
          </Setting>
        </Settings>
      </InstanceSettings>
      <Expression>
        <SimpleExpression>
          <ValueExpression>
            <XPathQuery>Values/KeyExists</XPathQuery>
          </ValueExpression>
          <Operator>Equal</Operator>
          <ValueExpression>
            <Value>true</Value>
          </ValueExpression>
        </SimpleExpression>
      </Expression>
    </Configuration>
    where am i doing it wrong

    Thanks & Regards, Suresh Gaddam

    Monday, December 22, 2014 8:25 AM

Answers

All replies