locked
When some users are selected in the Select People and Groups dialog, click OK gives another user. RRS feed

  • Question

  • Dears,

    I have a problem with MOSS 2007 "Select People and Groups dialog". When I search for user --> select a user --> click OK --> it gives me another user. This is happened for some users not all of them. 

    Why this happened? how to resolve it?


    • Edited by Mike Walsh FIN Wednesday, May 25, 2011 12:39 PM Original Title far too long. Essence retained in about half the text
    Wednesday, May 25, 2011 11:50 AM

Answers

  • Ok,

    Please run following command and check the result

    stsadm -o getproperty -propertyname peoplepicker-searchadforests

    check result, and if required run following command to set correct domain / forest again  

    stsadm -o setproperty -propertyname peoplepicker-searchadforests -propertyvalue <valid list of forests or domains>

    after running setproperty command do full user profile import once and then check behavior 


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by Wayne Fan Friday, June 3, 2011 6:37 AM
    Wednesday, May 25, 2011 1:24 PM

All replies

  • Hi,

    When it gives you another user , then is it the same user with some other domain ?

    i.e. you have selected ABC\Pratik.vyas and then you click on OK, so does it give you XYZ\Pratik.vyas ?

    If yes then this is due to user existence in multiple domain.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Wednesday, May 25, 2011 11:57 AM
  • No Pratik,

    This is an example to what happened:

    I select the following user: ABC\Anas.Alhussein

    Then it gives me after clicking OK: ABC\John.Hayek

    But this is happened for some users not all of them

    Thanks for your quick reply...


    Regards, Anas N. Alhussein Sharepoint Senior Developer
    Wednesday, May 25, 2011 12:06 PM
  • Ok , which criteria you are using to find users ?

    are you finding with any user ID or with Full Name ?

    Try with both scenario.

    And from you reply I assume that you are having only one domain, right ?

    Please let us know results after above testing.


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Wednesday, May 25, 2011 12:24 PM
  • Dear Pratik,

    Kindly see my results below:

    - We have only one domain

    - When searching by "Display Full Name" like "Anas N. Alhussein" it gives me two matches with the same (Display Name, Title, Department, Email) but with different Account Names:

    first match :     ABC\anas.hussein   (correct) --> click OK --> gives the right user

    second match : ABC\Jemy.Johnson (wrong)  --> click OK --> gives the wrong user

    - When searching by "Account Name" like "ABC\anas.hussein" it gives me one match with another different (Display Name, Title, Department, Email) of the correct one, but when Click on OK --> it gives me the right user

    result match :   ABC\Raul.Anderson (wrong) --> click OK --> gives the right user

    - When write the "Display Full Name" (Anas N. Alhussein) OR the "Account Name" (ABC\anas.hussein) in the "People Picker" Box (not the "Select People and Groups dialog") and click on "check names" button --> then it gives me the right user

    Strange behaviours!!! right???


    Regards, Anas N. Alhussein | Sharepoint Senior Developer
    Wednesday, May 25, 2011 1:18 PM
  • Ok,

    Please run following command and check the result

    stsadm -o getproperty -propertyname peoplepicker-searchadforests

    check result, and if required run following command to set correct domain / forest again  

    stsadm -o setproperty -propertyname peoplepicker-searchadforests -propertyvalue <valid list of forests or domains>

    after running setproperty command do full user profile import once and then check behavior 


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    • Marked as answer by Wayne Fan Friday, June 3, 2011 6:37 AM
    Wednesday, May 25, 2011 1:24 PM
  • I will check and get back to you next week


    Regards, Anas N. Alhussein | Sharepoint Senior Developer
    Wednesday, May 25, 2011 1:33 PM
  • Hi,

    Are you still facing the same problem ?

    did you get a change to follow my steps ?


    Warm Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Thursday, June 2, 2011 4:43 PM