none
Cannot create Folder and then add AppV sequenced apps in the Start menu

    Question

  • Hi,

    I have managed to sequence the apps properly using the App-V 5.0 SP2 sequencer. But after adding the package and publishing it globally, when i mount the package in my App-V client machine, it creates a direct application shortcut in the Start menu. What I want is to create all the App-V sequenced apps in a Folder in start menu so that users do not get confused by the overwhelming list of apps. Please suggest if there is a way possible.

    Thanks!

    Thursday, March 27, 2014 7:35 AM

Answers

  • The location of the shortcut is the one you chose during setup of your application. So initially you can change it while installing the application during sequence.

    You can also change the location of your shortcuts when sequencing is done, or by modified the deployment or userconfig afterwards.

    Have a look at the MS App-V 5.0 Sequencing Guide (page 33). At page 61 you can see how to change the config.xml afterwards.


    Thursday, March 27, 2014 8:20 AM
  • kshru,

    the shortcut in your screenshot is Windows' 'newly added, recently used or pinned shortcuts' location. 

    To validate whether your shortcut modification works you should go into the 'All Programs' section of the start menu.

    To avoid any streaming/publishing issues you could try to adjust the folder in the original package. To do so you've to use the 'add application' or 'update application' modification wizard and use the tabbed-editor.

    If the shortcut location is adjusted in the original package you could test it an a test machine without any deployment infrastructur. 

    [I'd recommend to create another thread about the fact that your packages don't get published nicely to the client - in fact you should see _something_ in the XML, but that depends on the publishing scope (machine/user..) ]


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Tuesday, April 01, 2014 12:42 PM
    Moderator

All replies

  • The location of the shortcut is the one you chose during setup of your application. So initially you can change it while installing the application during sequence.

    You can also change the location of your shortcuts when sequencing is done, or by modified the deployment or userconfig afterwards.

    Have a look at the MS App-V 5.0 Sequencing Guide (page 33). At page 61 you can see how to change the config.xml afterwards.


    Thursday, March 27, 2014 8:20 AM
  • Like Tiberivs said, you have many options to set and change shortcuts. One option that he forgot to mention:

    If you're using the management server, right-click your application. You can change shortcuts in the "2. Shorcuts" selection. Right-click the shortcut you want to change > "Edit shortcut" to change the location.

    Thursday, March 27, 2014 8:51 AM
  • Can we use 'edit shortcut' feature for an already published and mounted app? 

    I have tried doing that and it still appears in the Start menu as an application shortcut.

    I did edit shortcut to "[{Common Start Menu}]\AppV\", Is this the right way to do this?

    It doesn't get applied. Please help.

    • Edited by kshru Thursday, March 27, 2014 9:17 AM
    Thursday, March 27, 2014 9:01 AM
  • The edit shortcut feature works for me, just tested it with a fully cached and publish application.

    After changing the shortcut, do you re-sync the publishing server from the client?

    Did you changed the publishing server refresh schedule (10 minute delay)?

    http://support.microsoft.com/kb/2780177/en-us



    Thursday, March 27, 2014 1:17 PM
  • Hi Ben,

    Thanks for sharing this info.

    I tried it, and it still doesn't work. I am using App-V RDS client on Windows server 2008 R2, is there any issue with that?

    I tried to re-sync the pub server from the client, but I get this error, pls adv

    PS C:\Users\Administrator> import-module appvclient
    PS C:\Users\Administrator> Add-AppvPublishingServer -Name <Server> -URL <My pub server URL>
    Add-AppvPublishingServer : Failed to add the new server entry since there is already an entry with the same URL.
    Operation attempted: AddPublishingServer.
    AppV Error Code: 0700000704.
    Please consult AppV Client Event Log for more details.
    At line:1 char:1
    + Add-AppvPublishingServer -Name <Server> -URL <My pub server URL>
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult: (:) [Add-AppvPublishingServer], ClientException
        + FullyQualifiedErrorId : AddPublishingServerError,Microsoft.AppV.AppvClientPowerShell.AddAppvPublishingServer

    Friday, March 28, 2014 2:15 AM
  • Okay, I just checked my AppV client logs and looks like some issue with the connection to the pub server, error as follows :

    Getting server publishing data failed.
     URL: <My pub server URL>
     Error code: 0x45500D27 - 0x80190191

    Let me fix this and update you guys. Thanks for the help so far.

    Cheers!

    Friday, March 28, 2014 2:52 AM
  • I was facing a simalar issue this week, have a look at this topic. That errocode stands for an authentication issue, and may have several causes. So check your securty settings on the content share, and also in IIS (also make sure authenticated users is listed in the local user-group on your publishing server).
    Friday, March 28, 2014 8:46 AM
  • Hi 

    I managed to install App-V client on a new server and mount the package again.

    But still I can't seem to get it work the way I want. I want to see a Folder in the start menu hosting my App-V apps. Even though I have given the same setting in the APP-V management server, it still publishes the app directly in the start menu. I can't understand how else to test this. What am I missing? Pls point me correctly

    Ben De Vriese & Tiberivs

    Find some screenshots for better understanding the issue.

    Also when i try the Publishing server URL from my client machine or any machine, I get the below output. Has this got something to do with the problem I am facing? Is it able to load the changes that I am doing, any SQL permissions problem?

    <?xml version="1.0"?>

    -<Publishing Protocol="1.0">

    <Packages/>

    </Publishing>
    • Edited by kshru Tuesday, April 01, 2014 9:54 AM
    Tuesday, April 01, 2014 9:54 AM
  • Works for me.

    Tuesday, April 01, 2014 10:36 AM
  • Wow..cool :)

    So I am suspecting the issue must be something to do with permissions of my admin account to the App-V Management SQL DB, Its somehow not able to write changes to the DB I believe. Do you know any additional setup you did?

    And if you don't mind, could you please check from the client machine, 'http://<pub server:port> ' and let me know if it loads the package in the xml code? 

    Thanks much for sharing this!

    Tuesday, April 01, 2014 12:06 PM
  • I just followed the install procedure on Technet to install the infrastructure.

    Did you tried another location and foldername (other than Start Menu\AppV) ?

    Connecting to the AppV5 server (using a browser) on the publishing port should give you an XML doc, describing all packages (with GUIDs) and Connection Group GUIDs.




    Tuesday, April 01, 2014 12:14 PM
  • kshru,

    the shortcut in your screenshot is Windows' 'newly added, recently used or pinned shortcuts' location. 

    To validate whether your shortcut modification works you should go into the 'All Programs' section of the start menu.

    To avoid any streaming/publishing issues you could try to adjust the folder in the original package. To do so you've to use the 'add application' or 'update application' modification wizard and use the tabbed-editor.

    If the shortcut location is adjusted in the original package you could test it an a test machine without any deployment infrastructur. 

    [I'd recommend to create another thread about the fact that your packages don't get published nicely to the client - in fact you should see _something_ in the XML, but that depends on the publishing scope (machine/user..) ]


    Falko

    Twitter @kirk_tn   |   Blog kirxblog   |   Web kirx.org   |   Fireside appvbook.com

    Tuesday, April 01, 2014 12:42 PM
    Moderator
  • Hi guys,

    I finally got it to work. Thanks to you both. (kirk_tn and Ben De Vriese)

    It was actually, the 'edit default active directory access' option in which i needed to customize my start menu and also by adding the required groups. Thanks for the last post that prompted me to check this.

    Now it all works :-)

    Cheers all!!

    Wednesday, April 02, 2014 7:00 AM