Windows 7 using RDP to Server 2016 (login failed) RRS feed

  • Question

  • I am currently having an issue were Windows 7 computers can not connect (RDP) to Server 2016 (domain). Right away I get a "The logon attempt failed".

    I know that user information is correct, because I can connect using any Windows 10 computer. I have tried this from multiple Windows 7 computers, they all give the same error. I don't have any problems at all with Windows 10.

    So, this seems to be isolated to Windows 7.

    Has anyone seen this or know how to get around this issue?

    I appreciate your help!


    • Edited by enwoods01 Monday, March 6, 2017 9:59 PM
    Monday, March 6, 2017 9:35 PM

All replies

  • upgrade your Windows 7 to the latest update


    Remote Desktop Client does not support RD Gateway messaging. Verify that the Remote Desktop Resource Access Policy (RD RAP) for your RD Gateway server does not specify Only allow computers with support for RD Gateway Messaging or you will not be able to connect.

    Tuesday, March 7, 2017 6:02 AM
  • Hi enwoods01,

    First of all, please ensure all the machines (both the server and the Windows 7 clients) are up to date. The latest KB for server 2016 should be KB4010672 and the latest KB for Windows 7 should be KB3212646.

    Please try different credentials then check the symptom again.
    I have tested on my side. It is available for me to remote to a Server 2016 from a Windows 7 machine. So the issue should be related to the specific environment.
    Please check the Event Viewer for more information to troubleshoot this issue.
    Event Viewer(Windows Logs\Applications, System, Applications and Services\Microsoft\Windows\Remote Desktop Services ).

    Considering the issue is related to the Server 2016, we could try to ask for help from our Server forum at the same time.
    Windows Server 2016 General

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 7, 2017 6:37 AM
  •  below setting resolved the issue in our environment.

    Local Computer Policy -> Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host.

    RDP security level can be specify using policy named Require user of specific security layer for remote (RDP) connections. Enable this policy and in dropdown select RDP Security level.

    Hope this will help if you still facing this issue.

    Thursday, March 1, 2018 3:27 PM
  • edwoods01

    We had the same issue. It was due to the GPO on the Server 2016: Computer Configuration\Policies\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level being set to "Send NTLMv2 response only. Refuse LM & NTLM". It was fixed by changing this to "Send NTLMv2 response only." If you don't have the latest Windows patches installed you may need a lower setting like "Send LM & NTLM - user NTLMv2 session security if negotiated."



    • Edited by M a r k Thursday, March 21, 2019 7:45 PM
    Thursday, March 21, 2019 7:45 PM