locked
Clusters "Not monitored" RRS feed

  • Question

  •    I have 6.0.7291.0 version of the Windows Server Failover Cluster Management Pack.  All my clusters have "not monitored" status but at the same time all cluster nodes is monitored.

    'Allow this agent to act as a proxy and discover managed objects on other computers' checkbox is marked,




    • Edited by xeonzz Monday, March 6, 2017 1:30 PM
    Monday, March 6, 2017 1:07 PM

All replies

  • Hi ,

    This is usual . In the Administration workspace, cluster nodes will be displayed in Agent Managed, and the cluster will be displayed in Agentless Managed. The cluster will show as “not monitored” unless a management pack contains monitors that specifically target the cluster object. The agent on the active cluster node will perform all monitoring. If the node fails, the agent on the cluster node that clustering fails over to will begin monitoring, but the agent on the failover node will have no awareness of anything the agent on other node had monitored previously, such as alerts, state changes, and so forth. The agents are independent.

    Read https://technet.microsoft.com/en-us/library/hh212773(v=sc.12).aspx 

    Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!

    • Proposed as answer by sriraam raja kumar Monday, March 6, 2017 2:29 PM
    • Unproposed as answer by xeonzz Monday, March 6, 2017 2:47 PM
    Monday, March 6, 2017 2:29 PM
  • Hi,

    the first thing I would do is to empty the Health Service Cache on both the agent and SCOM Mgmt server side.

    If the are still shown as "not monitored" then you can look in the OperationsManager event logs on both sides and identify the related events. There should be a reason for this and usualy this is logged in the OperationsManager event log.

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!)

    Monday, March 6, 2017 2:41 PM
  • I have "not monitored" status in Monitoring\Microsoft Windows cluster\Cluster\Cluster State
    • Edited by xeonzz Monday, March 6, 2017 2:48 PM
    Monday, March 6, 2017 2:47 PM
  •  i have alredy did it. There is nothing about warning or critical events.
    • Edited by xeonzz Monday, March 6, 2017 2:50 PM
    Monday, March 6, 2017 2:50 PM
  • Hello,

    Please make sure that all cluster nodes has agent installed, And all cluster nodes are enabled as proxy.

    Please also right click the cluster, and open the Health Explorer for it, check is there any monitors target to it.

    Regards,

    Yan Li


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 7, 2017 5:33 AM
  • all nodes is ok. If we click on cluster health explorer we see only not monitored status for all monitors.
    • Edited by xeonzz Tuesday, March 7, 2017 6:15 AM
    Tuesday, March 7, 2017 6:13 AM
  • Take a look at the following to see if it applies to you:

    Having an SQL Server cluster resource group that contains more than one network name resource might mean that the clustered SQL Server resource is not monitored. For more information, see Knowledge Base article 919594.

    You can do Get-ClusterResource to see how many network resources a cluster has. 

    Wednesday, March 8, 2017 3:33 PM
  • I have a problem with no only slq clusters, for example dag, hyper-v...
    Friday, March 10, 2017 5:34 AM
  • Hi,

    have you considered removing, cleaning up and re-importing the MP?

    Regards,

    Stoyan


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!)

    Friday, March 10, 2017 7:37 AM
  • I have done it. It still does not work.
    Wednesday, March 15, 2017 2:09 PM