locked
Search Service Application in Faulted State RRS feed

  • Question

  • I have configured my FAST setup and have the components talking to each other, I can check the FAST Query SSA and using the FAST Search Administration I can select Managed Properties and get the list - so I know the components are installed.  The Query is running in the Search Content SSA, the log shows success on the SharePoint site.  When using the FAST Search page I get:

    The Search Request was unable to connect to the Search Service

    In the ULS log I find the following error:

    SearchServiceApplication::Execute--Exception: Microsoft.Office.Server.Search.Query.SearchServiceNotFoundException: Service fault communicating with query service http://localsp06.ihi.com:13287; The communication object, System.ServiceModel.Channels.ServiceChannel, cannot be used for communication because it is in the Faulted state.

    at Microsoft.Office.Server.Search.Query.Gateway.FastSearchGateway.GetQueryResult(IQuery query)

    at Microsoft.Office.Server.Search.Query.Gateway.FastSearchGateway.ExecuteSearch(SearchRequest request, String queryString)

    at Microsoft.Office.Server.Search.Query.Gateway.AbstractSearchGateway.Search(SearchRequest request)

    at Microsoft.Office.Server.Search.Query.FASTQueryInternal.ExecuteSearch(SearchRequest request, ResultTableCollection rtc)

    at Microsoft.Office.Server.Search.Query.FASTQueryInternal.Execute(QueryProperties properties)

    at Microsoft.Office.Server.Search.Administration.SearchServiceApplication.Execute(QueryProperties properties)

    Not sure what to do at this point as I have gone through all the configuration steps twice, with everything else working correctly this seems like an odd step to just fail

    • Edited by Michael__F Monday, May 17, 2010 8:15 PM editing
    Monday, May 17, 2010 1:11 PM

All replies

  • Hi Michael, did you ever find a solution to this problem?  I am having the same exact symptoms.
    • Edited by MattSnyder Friday, October 25, 2013 9:48 PM
    Friday, October 25, 2013 9:47 PM
  • For the FAST aspect no, never resolved it.

    We ended up just using the SharePoint Enterprise Search Service Application and that was much simpler to set up.

    Monday, October 28, 2013 1:13 PM
  • Hello,

    Fast Search for SharePoint 2010 is time sensitive environment.  When we see this error we have found that the servers are not in synch (>1minute).

    Can you verify that your servers have the time is in synch?

    Best Wishes,

    Michael Puangco

    Monday, November 18, 2013 5:02 AM