locked
Bing - unable to search keyword RRS feed

  • Question

  •  

    we have IE9. If we type just a key word for bing, it is giving an error "internet explorer cannot display the webpage".

    If I search with complete web address I get to web pages, but if I don't have the web page and I type in a word in Bing, it shows its searching but giving error.

    We have about 2500 employees, everyone are using IE 9. Please help!!

    Thanks.

    Thursday, July 31, 2014 4:22 AM

Answers

  • Hi,

    It is unclear from your question whether you are using the Bing toolbar or the Bing Search Provider...

    Fist start IE in noAddons mode... (to rule out the Bing toolbar or another toolbar/bho addon)

    try searching from the Address bar with your default Search Provider...using the ? prefix...

    eg.

    ? searchterms instead of searchterms

    If that works then it is your Bing Toolbar or another toolbar installed on your machines is the cause.... Post back with your answer.

    If it doesn't work then it is some middleware that you have installed on your network.. your proxy server?....

    Use a network sniffing tool (http://telerik.com/fiddler ) to examine the outbound request when you do a search.

    Post back with the request header, particularly the userAgent string value.... and the actual request uri.

    also go Tools>Manage Addons>Search Providers, select your Bing Search Provider and post back with the URI value... possibly you have deployed the wrong SearchProvider URL with GPO.

    my value is http://www.bing.com/search?q=&src=IE-SearchBox&FORM=IE11SR

    (the IE11SR part is new.... possibly your have something like FORM=IE8...use GPO to change your Bing and Default Search Provider to the above....or you can go to IEGallery.com to download the Open Search Description file)

    A third possibility is a URLSearchHook, but IE8 and higher is hardened against that type of malware... I will wait for your responses before suggesting a fix for SearchHook hijacking.


    Rob^_^

    Also post back with the full address from the IE address bar... we are looking for Unicode characters... Make sure that View>Encoding>UTF 8 is selected from the IE menu.

    (I am not sure of the GPO setting that may control that).

    Thursday, July 31, 2014 7:35 AM
  • Hi,

    In addition, notice if you have a search icon on the right side of  address bar:

    According to your description, this issue would affect the whole environment. If you mean you cannot search in the address bar via Bing provider, you need check this group policy:

    User Configuration, Administrative Templates, Windows Components, Internet Explorer, Internet Settings, Advanced settings, and then select Searching in the left column of the Group Policy editor


    Alex Zhao
    TechNet Community Support

    • Marked as answer by Michael_LS Thursday, August 7, 2014 11:58 AM
    Friday, August 1, 2014 2:52 AM

All replies

  • Hi,

    It is unclear from your question whether you are using the Bing toolbar or the Bing Search Provider...

    Fist start IE in noAddons mode... (to rule out the Bing toolbar or another toolbar/bho addon)

    try searching from the Address bar with your default Search Provider...using the ? prefix...

    eg.

    ? searchterms instead of searchterms

    If that works then it is your Bing Toolbar or another toolbar installed on your machines is the cause.... Post back with your answer.

    If it doesn't work then it is some middleware that you have installed on your network.. your proxy server?....

    Use a network sniffing tool (http://telerik.com/fiddler ) to examine the outbound request when you do a search.

    Post back with the request header, particularly the userAgent string value.... and the actual request uri.

    also go Tools>Manage Addons>Search Providers, select your Bing Search Provider and post back with the URI value... possibly you have deployed the wrong SearchProvider URL with GPO.

    my value is http://www.bing.com/search?q=&src=IE-SearchBox&FORM=IE11SR

    (the IE11SR part is new.... possibly your have something like FORM=IE8...use GPO to change your Bing and Default Search Provider to the above....or you can go to IEGallery.com to download the Open Search Description file)

    A third possibility is a URLSearchHook, but IE8 and higher is hardened against that type of malware... I will wait for your responses before suggesting a fix for SearchHook hijacking.


    Rob^_^

    Also post back with the full address from the IE address bar... we are looking for Unicode characters... Make sure that View>Encoding>UTF 8 is selected from the IE menu.

    (I am not sure of the GPO setting that may control that).

    Thursday, July 31, 2014 7:35 AM
  • Hi,

    In addition, notice if you have a search icon on the right side of  address bar:

    According to your description, this issue would affect the whole environment. If you mean you cannot search in the address bar via Bing provider, you need check this group policy:

    User Configuration, Administrative Templates, Windows Components, Internet Explorer, Internet Settings, Advanced settings, and then select Searching in the left column of the Group Policy editor


    Alex Zhao
    TechNet Community Support

    • Marked as answer by Michael_LS Thursday, August 7, 2014 11:58 AM
    Friday, August 1, 2014 2:52 AM
  •   If we type just a key word

    "word" is the most significant part of your symptom description.  See what happens if you make it "words" e.g. more than one word or enter a properly prefixed search?

    The problem is that you are also allowing the possibility for the users to enter Intranet "addresses" without a protocol prefix.  Clearly you can't have both unprefixed requests for single word Intranet "addresses" and entry of a single word that is expected to be construed as an implicit search.  Either mandate protocol prefixes for Intranet addresses or mandate explicit searching.  The latter would be easiest and most reliable IMO.  E.g. just tell everyone that if they want to do an Internet search from the Address bar to press Ctrl-e first.

    FYI



    Robert Aldwinckle
    ---

    Friday, August 1, 2014 12:07 PM
    Answerer