locked
Can not disable Virtual Wifi adapter after wireless driver update RRS feed

  • Question

  • I wanted to disable the virtual WiFi hosted network feature due a security reasons by netsh commands:
    netsh wlan stop hostednetwork
    netsh wlan set hostednetwork mode=disallow

    That worked as expected, the "Microsoft Virtual WiFi Miniport Adapter" has disappeared from Device Manager and it also persisted after reboot. No issue yet.

    After updating the Intel wifi driver I see two virtual wifi adapters in Device Manager now:

    Microsoft Virtual WiFi Miniport Adapter
    Microsoft Virtual WiFi Miniport Adapter #2

    Disabling it by these netsh commands above no longer works (no error reported, but it still remains in Allowed state). I have tried to disable and delete them, reboot, uninstall the driver completely and reinstall ... still the same result. Reverting back to the previous Intel driver solves it but I would prefer to have the most recent one.

    Is possible to track what (Intel) wireless drivers are the origin of their "virtual wifi" children ?

    Friday, June 14, 2013 9:47 AM

Answers

  • Then you need to check with Intel on this.

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by tracycai Friday, June 21, 2013 2:14 AM
    Tuesday, June 18, 2013 5:07 PM
    Answerer

All replies

  • Hi,

    In my option, we need to choose the most appropriate driver for our computer. If everything works fine with the previous version, I would not install another one.


    Tracy Cai
    TechNet Community Support

    Monday, June 17, 2013 3:13 AM
  • Hi,

    In my option, we need to choose the most appropriate driver for our computer. If everything works fine with the previous version, I would not install

    The reason is that new version contains fixes for a security vulnerability issue.
    Tuesday, June 18, 2013 10:43 AM
  • Then you need to check with Intel on this.

    Arnav Sharma | Facebook | Twitter Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by tracycai Friday, June 21, 2013 2:14 AM
    Tuesday, June 18, 2013 5:07 PM
    Answerer