none
missing "BIZTALK SERVER APPLICATION PROJECT" template RRS feed

  • Question

  • Hi,

    I am trying to configure-automatic-deployment-with-visual-studio-team-services-in-biztalk, I followed couple of sites and installed biztalk server feature pack 2 in biztalk server but i cant see "BIZTALK SERVER APPLICATION PROJECT" template in visual sudio 2015.

    what is best way to get this template?


    Friday, June 5, 2020 11:18 AM

All replies

  • Did you install Visual Studio before installing the BizTalk SDK?   If no, rerun the BizTalk Installation and re-install the SDK.
    Monday, June 8, 2020 10:48 PM
  • Hi Colin,

    Yes  it is my dev enviroment, so we have visual studio and biztalk server.

    when we setup my dev enivroment we install feature pack 3, later i uninstall pack3 to install feature pack2.

    Still i am unable to see that particular template, can you help me on this issue.

    Wednesday, June 17, 2020 7:18 AM
  • Why did you uninstall Feature Pack 3?  I would recommend you install Feature Pack 3 CU 7,  https://aka.ms/bts2016fp3, that includes the previous Feature Packs and all the Cumulative Updates
    Wednesday, June 17, 2020 9:03 AM
  • Hi 

    I Install Feature Pack 3 along with Feature pack 2, Still i can't see "Biztalk Sever Application Project" template 

    can i install Feature Pack 3 if already i have Feature pack 2 in my machine.

    Monday, June 22, 2020 5:31 AM
  • Feature Packs are cumulative, so you only need install the latest one to get all the feature from previous Feature Packs. 

    The reason I don't recommend uninstalling Feature Packs or CUs is that there is often a SQL script in them to fix issues at the Database level, and these DO NOT get rolled back if you uninstall.

    I would suggest re-running the BizTalk installer and telling it to install/repair the BizTalk Development SDK and then re-install Feature Pack 3 CU7.




    Monday, June 22, 2020 9:02 PM