locked
Cannot relay email RRS feed

  • Question

  • We have an Exchange 2007 mailbox CCR, 2 Server configured as Hub/CAS and an Edge server. The mailflow is working fine. We are using Postini for email filtering services. The issue is that sometime mail sent by a user to multiple recipient gets resend multiple times even if only a single recipient's server rejects mail for some reason. We found that while trying to reinject the email back to Edge Server, the email fails because of which it sends multiple copies.

    Though we have configured our Edge Server as mentioned in Postini's guide but when their support engineer is trying to check the reinjection, he is getting error which I have copied below.

    -bash-3.2$ telnet 195.66.100.34 25
    Trying 195.66.100.34...
    Connected to 195.66.100.34 (195.66.100.34).
    Escape character is '^]'.
    220 ADAHO-SEDG01.ADA.NET Microsoft ESMTP MAIL Service ready at Mon, 18 Apr 2011 11:02:44 +0300
    ehlo dummy.net
    250-ADAHO-SEDG01.ADA.NET Hello [207.126.144.184]
    250-SIZE 10485760
    250-PIPELINING
    250-DSN
    250-ENHANCEDSTATUSCODES
    250-STARTTLS
    250-AUTH
    250-8BITMIME
    250-BINARYMIME
    250 CHUNKING
    mail from:<>
    250 2.1.0 Sender OK
    rcpt to:<any@one.tld>
    550 5.7.1 Unable to relay
    quit
    221 2.0.0 Service closing transmission channel
    Connection closed by foreign host.

    I would like to know how can we resolve this issue.


    Fazal Ur Rehman Shah | Senior Consultant
    Monday, April 18, 2011 11:05 AM

Answers

  •  

    How do you archive the relay function? Do you use any application server?

     

    As an additional information, I suggest you refer to the following article to configure Relay in Exchange 2007.

     

    http://exchangepedia.com/2007/01/exchange-server-2007-how-to-allow-relaying.html

     

    Thanks.

    Novak


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Novak Wu Friday, May 6, 2011 2:57 AM
    Thursday, April 21, 2011 6:54 AM

All replies

  • On Mon, 18 Apr 2011 11:05:11 +0000, Fazal Ur Rehman wrote:
     
    >We have an Exchange 2007 mailbox CCR, 2 Server configured as Hub/CAS and an Edge server. The mailflow is working fine. We are using Postini for email filtering services. The issue is that sometime mail sent by a user to multiple recipient gets resend multiple times even if only a single recipient's server rejects mail for some reason.
     
    Do you see the same set of RCPT TO addresses send by your Edge server
    to Postini? A "rejection" would be a 5xx status code, which is a fatal
    error. In that case the RCPT TO command shouldn't be retried at all.
     
    >We found that while trying to reinject the email back to Edge Server, the email fails because of which it sends multiple copies.
    >
    >Though we have configured our Edge Server as mentioned in Postini's guide but when their support engineer is trying to check the reinjection, he is getting error which I have copied below.
    >
    >-bash-3.2$ telnet 195.66.100.34 25 Trying 195.66.100.34... Connected to 195.66.100.34 (195.66.100.34). Escape character is '^]'. 220 ADAHO-SEDG01.ADA.NET Microsoft ESMTP MAIL Service ready at Mon, 18 Apr 2011 11:02:44 +0300 ehlo dummy.net 250-ADAHO-SEDG01.ADA.NET Hello [207.126.144.184] 250-SIZE 10485760 250-PIPELINING 250-DSN 250-ENHANCEDSTATUSCODES 250-STARTTLS 250-AUTH 250-8BITMIME 250-BINARYMIME 250 CHUNKING mail from:<> 250 2.1.0 Sender OK rcpt to:<any@one.tld> 550 5.7.1 Unable to relay quit 221 2.0.0 Service closing transmission channel Connection closed by foreign host.
    >
    >I would like to know how can we resolve this issue.
     
    I'd have to guess that one.tld isn't an "Accepted Domain" in your
    Exchange organization, or there's a problem with the edge
    synchronization. If it's the former, add the missing domain and force
    the edge sync. If it's the latter, tear down the edge sync and
    recreate it.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Tuesday, April 19, 2011 1:23 AM
  •  

    How do you archive the relay function? Do you use any application server?

     

    As an additional information, I suggest you refer to the following article to configure Relay in Exchange 2007.

     

    http://exchangepedia.com/2007/01/exchange-server-2007-how-to-allow-relaying.html

     

    Thanks.

    Novak


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Novak Wu Friday, May 6, 2011 2:57 AM
    Thursday, April 21, 2011 6:54 AM