none
HYPER-V 2016 Host after error event-id 19062 - HYPER-V VMs are frozen

    Question

  • Hi,

    I have a big problem with a HYPER-V 2016 (Std.) host and frozen VMs.

    On the host, 8 VMs run with replication on a second host. The replication interval is every 15 min.

    All work fine for 2-3 days - until a first event-id error on one VM guest occurs (no error before!):

    ****************************************************************************************************

    Timeout for "VM1 guest SRV" while waiting for execution of the "Create a reference point" operation. The virtual machine is currently doing the following: "Deprecated reference points are cleaned". (ID of virtual machine: 573ADD49-CFF3-4B24-B2E9-76767E0BCFC3)

    protocoll-Name: Microsoft-Windows-Hyper-V-VMMS/Admin
    source: Hyper-V-VMMS
    event-id: 19062
    Level: error
    user: SYSTEM

    ****************************************************************************************************

    After this error an event-id: 33680 occurs followed by event-id: 32546 and event-id: 32026 (error while deltageneration)

    After this first error, it takes about 5-15 minutes and other VMs report the same error.

    Then all VMs run into the same error (every 5-15 min.)

    If the last VMs generate this error -  It starts to freeze all VMs.

    All VMs Show the Status: "Creating a reference point - planned"

    On the first VMs this status is shown in 2-3 instances.

    On this point all VMs not more accessible. Only a HYPER-Host reboot solve the problem (for the next 2-3 days).

    It is striking that the replication goes bad - status critical. It must be renewed.

    What have I done:

    Memory is still very much free.  70 GB from 128 GB

    CPU have only 6-7 % ussage.

    Disk storage is still very much free. (DAS with ReFS)

    What is the Problem? Who can help me?

    Thanx.


    Danke und liebe Grüße Oliver Richter

    Tuesday, March 21, 2017 1:36 PM

All replies

  • Hi,

    Have you tried to remove the replication to see if it helps?

    Did you make any changes before the issue happen?

    Since I could not find related information of the issue, I suggest you open a case with Microsoft, more in-depth investigation can be done so that you would get a more satisfying explanation and solution to this issue.
    Here is the link:
    https://support.microsoft.com/en-us/gp/contactus81?Audience=Commercial&wa=wsignin1.0

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 22, 2017 1:53 AM
    Moderator
  • Thanks @Leo

    Have you tried to remove the replication to see if it helps?

    -> Since yesterday I have restricted the replication to only one VM. I will wait the next 2-3 days what will happen.

    Did you make any changes before the issue happen?

    -> Difficult question! The host is new since January 2017. Until about 3 weeks ago, everything was inconspicuous. The host was not changed.
    Also the Defender is deactivated.

    The effect also occurred before the March Patchday. So it can not be related. The March patches were installed in the hope of improvement.

    BR Oliver


    Danke und liebe Grüße Oliver Richter

    Wednesday, March 22, 2017 8:53 AM
  • Hello Oliver,

    Were you able to find a fix for this issue?  We are experiencing a very similar issue.  We are running a 3 node Windows Server 2016 Hyper-V cluster with about 20 virtual machines.  All VM's are replicated to a stand-alone 2016 Hyper-V host server.

    Every few days one of the VM's stops responding with a hyper-v status of 'Deleting a reference point'.  Sometimes we are able to live migrate the other VM's off the host, but sometimes the live migration hangs at 84%.  In all cases the host server needs to be rebooted.  The event log is riddled with 19062 errors.

    Once everything is back up the hyper-v replica needs to be resynced.

    Monday, May 29, 2017 2:07 PM
  • I had the same issue here with 3 hyper-v  (windows server 2016 Datacenter)cluster with SOFS deploy.

    This issue will only affect on VM placed on SOFS , will not affect VM on CSV.

    Here is the work around. (Since I treat this more as a bug and no officially KB or patch or even hotfix.)

    Try not disable Windows Defender (Yeah, also check your GPO setting), restart ,

    once that's enabled run the following in powershell (to add exclusions)

    Set-MpPreference -ExclusionPath c:\clusterstorage, %ProgramData%\Microsoft\Windows\Hyper-V, %ProgramFiles%\Hyper-V, %SystemDrive%\ProgramData\Microsoft\Windows\Hyper-V\Snapshots, "%Public%\Documents\Hyper-V\Virtual Hard Disks"

    Set-MpPreference -ExclusionProcess %systemroot%\System32\Vmwp.exe, %systemroot%\System32\Vmms.exe -Force

    Set-MpPreference -ExclusionExtension *.vhd, *.vhdx, *.avhd, *.avhdx, *.vsv, *.iso, *.rct, *.vmrs, *.vmcx

    good luck!

    Friday, February 09, 2018 7:42 AM
  • Thanks @sean_svc 

    We have now completely uninstalled the Windows Defender feature on the Hyper-V hosts.

    That made it a little better. The freezing takes place only every few weeks/months.

    In the meantime, however, we are starting from a hardware defect because the host, even at maximum load, reports other errors in the CPU and storage area. According to Supermicro, this indicates a CPU or motherboard error.

    We will do an exchange in the next few days/weeks. 


    Danke und liebe Grüße Oliver Richter

    Friday, February 09, 2018 8:29 AM