locked
Streaming AppV 5.0 SP2 package and "Running as Administrator" RRS feed

  • Question

  • Background Info:

    AppV 5.0 SP2 Sequencer on Windows 7 x64 SP1 with patches up to Feb 19, 2015.

    I virtualized the SCCM 2012 R2 Admin Console Update 3 with pre-reqs, MDT 2013 Toolkit, and Dell Right Click Tools. I deploy this application using SCCM 2012 R2. When I deploy the application to a physical workstation running Windows 7 x64, the package deploys and I am able to right click on the Desktop shortcut and choose "Run As Administrator" without issue. The application launches and everything works. If stream this same package to a VDI machine running on VSphere View 6, the application streams without issue. When I right click and choose "Run as Administrator" nothing happens after I type my credentials into the UAC prompt. If I just double click the shortcut, the console launches without issue but I have no permissions to modify anything with my normal account. I ran ProcMon but saw no errors or issues. Any suggestions?

    Monday, March 9, 2015 3:29 PM

Answers

All replies

  • Hello,

    What happens if you natively install this onto the VDI-machine and perform the same test?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, March 9, 2015 3:30 PM
  • The software works natively installed. We use non-persistent VDI clones on my network and we want to eliminate the need to install the software every day. They are also cleaning up and removing as many physical workstations on our network as possible, so using a physical workstation will not be a solution soon.
    Monday, March 9, 2015 3:38 PM
  • Have you tried setting runasinvoker?

    http://packageology.com/2013/06/app-v-5-uac-file-virtualisation-virtualstore/

    It may require further elevation but this may suffice. Also, you should take a look at the policies being applied to your physical desktops vs virtual...


    PLEASE MARK ANY ANSWERS TO HELP OTHERS Blog: rorymon.com Twitter: @Rorymon

    Monday, March 9, 2015 4:28 PM
  • Hello,

    Did the native installation happen within the VDI-machine?


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, March 9, 2015 5:06 PM
  • Yes I have done the native install on the VDI machine and it works without issue.
    Monday, March 9, 2015 5:09 PM
  • Hello,

    I suggest you use Process Monitor to compare what happens when using the application in a native installation on the VDI-machine compared to a virtualized instance. Most likely there is a difference in behaviour and idenitifying this would give an idea where to investigate further. 


    Nicke Källén | The Knack| Twitter: @Znackattack

    Monday, March 9, 2015 5:15 PM