locked
File Upload Hangs RRS feed

  • General discussion

  • I have a staging/test farm with 2 Windows NLB configured WFEs with ForeFront installed (and one application server) and the web application was originally implemented as https only (there is no web app on port 80!) .  If real time scanning is enabled, the upload file process hangs.  If I disable real time scanning, the same file uploads just fine.  A manual on-demand scan seems to run fine across all sites.  I have not enabled forefront tracing yet, but plan on tackling that tomorrow but was hoping others might have some ideas for me.  I've tried to duplicate the issue in a DEV environment where I'm using the stand-alone install of SP 2010 and everything works fine (kind of expected it would).

    • Environment:  SharePoint 2010 with Oct 2010 Cumulative update
    • 2 WFE, 1 App Server
    • SSL only web application
    • won't go into all the details around service accts, but using sp_farm and sp_install type account best practices.  used sp_install as acct for ForeFront and had to add this account to SQL sysadm role

    I have NOT tried the steps in this KB article yet (keep getting interrupted at work :-/ )  http://support.microsoft.com/kb/952167

    Again, hoping someone else came across this issue or someone can point me in direction for additional troubleshooting.  We're new to the ForeFront products.

    Thank in advance.

    -Jim

    Friday, January 28, 2011 6:24 AM

All replies

  • Here's an update for everyone.  Patience is a virtue.  The first file upload to either web server is what seems to take an eternity, several minutes for the smallest text file.  After the first scan however, then all subsequent scans are quick.  It is somehow related to the FSCController (or dependant service) service as a restart of this service will cause the first file upload to take several minutes again.  When this service is started, I also notice a 10016 DCOM error in the event log related to the sp_webapp account (I'd have to dbl check my notes at work as to what all the services are that are running under this account).

    I'll provide more updates as I get them.

    Monday, January 31, 2011 3:18 AM
  • Hi,

     

    Thank you for the post.

     

    “When this service is started, I also notice a 10016 DCOM error in the event log related to the sp_webapp account” – would you please tell us the detailed error message? It looks like for some reason you may be missing some DCOM permissions on your servers.

     

    Regards,


    Nick Gu - MSFT
    Monday, January 31, 2011 6:04 AM