none
RWA HTTP problem RRS feed

  • Question

  • IF i try to connect to Http://mail.ipelec.biz i get a windows security log on screen

    Before configuring the gateway a user name and password is required. The server is requesting you connect to the server in an insecure manner. Basic authentication without security.

    So i do not get redirected to https://mail.ipelec.biz  remote web login screen.

     Further when i do sucessfully connect with Https://mail.ipelec.biz and then connect to the server. I am presented with downloading the remote desktop active x client which i do sucessfully.

    Remote desktop connection then comes up and it is a proper  address and matches the go daddy 5 year standard cert  mail.ipelec.biz

    Windows security tab comes up next and i type in my domain credentials

    Then i get a warning that the certificate name is not correct Server.ipelec.local

    if i view the certificate i see that it is a ca root certificate not trusted and exires

    in 6 months. I am able to continue and get connected.

    I have a go daddy ssl standard certificate for mail.ipelec.biz for 5 years

    but it does not seem to be referenced past the initial login. WHAT HAPPENS IN 6 MONTHS

    WHEN THE CA ROOT CERTIFICATE EXpires for Server.ipelec.local

    Can't i use the go daddy cert for everything?

    Why doesn't the http://mail.ipelec.biz resolve automatically to

    https://mail.ipelec.biz/remote login page.

    http://mail.ipeec.biz/owa does not work but https://does

    I am ok with just using https but am concerned about the ca root expiring in 6 months.

    Dale Bush

    Affordable computer Services

    114 E Beaufort ST / Lower Level

    Normal IL 61761

    309-452-7070

    dale@affordputerservices.com

    Tuesday, June 14, 2011 10:17 PM

All replies

  • Hi Dale,

     

    Thanks for posting here.

     

    You should contact the cert issuer for a new cert and import it by using “Add a trusted certificate” wizard or manually input it if the third party certificate you purchased form Go Daddy has expired.

    For more information please refer to the links below first :

     

    Receiving Certificate Errors When Connecting to Clients/Servers with TS Gateway or Remote Web Workplace on SBS 2008

    http://blogs.technet.com/b/sbs/archive/2008/10/03/receiving-certificate-errors-when-connecting-to-clients-servers-with-ts-gateway-or-remote-web-workplace-on-sbs-2008.aspx

     

    How to Manually Install Certificates in SBS 2008

    http://blogs.technet.com/b/sbs/archive/2009/12/14/how-to-manually-install-certificates-in-sbs-2008.aspx

     

    Installing a GoDaddy Standard SSL Certificate on SBS 2008

    http://sbs.seandaniel.com/2009/02/installing-godaddy-standard-ssl.html

     

    Thanks.


    Tiger Li
     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 16, 2011 7:03 AM
  • Hi Dale,

    Please feel free to let us know if the information was helpful to you.

    Thanks,

    Tiger Li

    TechNet Subscriber Support in forum
    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, June 20, 2011 1:54 AM
  • i am sorry i guess you only read the secnd part of the posting regarding ssl ca rot cert.

    i have two concerns

    1. People have to type https://mail..ipelec.biz to get directed to the remte login page they do not get rerouted there if they type http://mail.ipelec.biz

    You can try tping http:mail.ielec.biz and https://mail.ipelec.biz  to see the difference if you wish.2

    2. the ca root certificate for ts gateway is server.ipelec.local and expires in 6 months I want it to go longer than that or reference the go daddy cert we purchased for mail.ielec.biz  . below are the stes as to when i am prompted with a ts gateway cert.

     Further when i do sucessfully connect with Https://mail.ipelec.biz and then connect to the server. I am presented with downloading the remote desktop active x client which i do sucessfully.

    Remote desktop connection then comes up and it is a proper  address and matches the go daddy 5 year standard cert  mail.ipelec.biz

    Windows security tab comes up next and i type in my domain credentials

    Then i get a warning that the certificate name is not correct Server.ipelec.local and expires in 6 months

    i wish t fix this probem, and the http issue thanks

    dale

                                                                                 

     

     


    dale bush
    Monday, June 20, 2011 8:36 PM
  • Hi dale,

     

    Thanks for update.

     

    > People have to type https://mail..ipelec.biz to get directed to the remte login page they do not get rerouted there if they type http://mail.ipelec.biz

    It appears a HTTP to HTTPs redirecting issue. Is this domain name for your SBS RWW or OWA site? and which SBS version is running now?

    Please refer to the links below and recheck your IIS settings first :

     

    A Method to Configure Outlook Web Access Redirection in SBS 2008

    http://blogs.technet.com/b/sbs/archive/2008/12/24/a-method-to-configure-outlook-web-access-redirection-in-sbs-2008.aspx

     

    How to redirect requests from HTTP to HTTPS or to the OWA virtual directory in IIS 7

    http://support.microsoft.com/kb/975341

     

    For your second issue, according the description , it appears that the RWW TS service is still using the old certificate for incoming authentication, so you should import the new purchased third party certificate and enroll to your clients , meanwhile you should also configure TS service to use this certificate for SSL connection with following the introduction in the blog post below:

     

    Common Remote Web Workplace (RWW) Connect to a Computer Issues in SBS 2008

    http://blogs.technet.com/b/sbs/archive/2009/06/19/common-remote-web-workplace-rww-connect-to-a-computer-issues-in-sbs-2008.aspx

     

    For more information please also refer to the articles in the link below:

     

    http://blogs.technet.com/b/sbs/archive/tags/rww/

     

    Thanks.

     

    Tiger Li

     

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, June 21, 2011 3:57 AM
  • Well it looks that this will help the second problem, hopefully.I will try this this weekend July4th

     

    i type http://mail.ipelec.biz and expect to get forwarded to https://mail.ipelec.biz/Remote/logon?ReturnUrl=%2fremote

    which is what happens when i type http://mail.affordputerservices.com i get redirected to https://mail.affordputerservices.com/Remote/logon?ReturnUrl=%2fremote


    dale bush
    Saturday, July 2, 2011 3:45 PM
  • ok this is sbs 2011 that i am connecting to.

    I put the address there so yu could see what happens.

    When i type http://mail.ipelec.biz i expect to get https://mail.ipelec.biz/remote and then have to type in a user name and password to rwa

    instead i get a windows security screen and it will not accept my user name / password,or domain\user name password

    however if i type https://mail.ipelec.biz i get routeed to https://mail.ipelec.biz/remote and from Remote web anywhere i can log in

     

    now that i am logged into the remote web anywhere i can select to connect to a server

    i do so and see a certificate from go daddy of mail.ipelec.biz for remote destop connection

    i next get a windows security dialog box to connect to the remote desktop gateway server

    i enter the user name and password and see a certificate from the server with server name.local that expires in 6 months

    not the go daddy one that expires in 5 years.

    i have enabled remote desktop gateway manager and installed the go daddy cert and reread everything on importing a go daddy cert.

     

    i have worked on this off and on for 2 -3 weeks. other people have this probem too. I have even signed up on experts exchange and they do not have an answer.

    i will pay 50 dollars cash if this can be resolved. dale bush

     

     


    dale bush
    Tuesday, July 5, 2011 3:05 AM