problems with send connector - Bad sequence of commands (503)


  • Hi!


    I have problems with my freshly installed E2K7 und windows 2003 R2 x64. It is a single server with a hub role installed. I have no edge server installed, but I tried a few smarthosts (Linux, BSD) and some smtp servers on the internet.


    I configured the send connector with * for the destination domains. First I received only meaningless errors through that mail queue gui, than I tried "set-sendconnector -ProtocolLoggingLevel:Basic". I got some information about "bad sequence of commands". I sniffed the network and I got this:


    220 mail.webpage.t-com.de ESMTP server ready Fri, 6 Jul 2007 15:02:59 +0200

    EHLO givo-innovativeprojekte.de










    250 SIZE 28672000


    334 VXNlcm5hbWU6


    334 UGFzc3dvcmQ6


    235 Authentication successful

    RCPT TO:<someone
    @gmx.de>  (changed)

    503 Bad sequence of commands (specify MAIL first)




    It looks like exchange12 unlearned smtp, cause there must be "MAIL FROM<someone@domain.com" prior to "RCPT TO"???


    I've tried telnet on port 25 and I could send email, but that was telnet. Our smarthosts send the same smtp-error 503.


    What shall I do? Please can you help me a little further.





    Friday, July 06, 2007 5:47 PM


  • Unbelivable but true: The solution is quite simple: Replace the network drivers. In our case it was Intel Pro 1000 Driver from 4/2006, Now we have a driver from 10/2006, all problems have gone.......


    Thursday, September 13, 2007 2:12 PM

All replies


    Let me assure you that Exchange12 RTM does send MAIL FROM: before RCPT TO:. One thing I noticed is suspicious, you write:




    Before we released E12, we changed that to:




    in order to have more categories of logging in a later version, and basic didn't turn out to be basic anymore. So you are apparently running some prerelease version, and given this basic failure (that should fail any attempt to make it leave campus) I suspect it's not even a pre release.


    Also, since you sniffed the network, can you post the products protocol log itself instead? And/Or post the version of the following DLL: Microsoft.Exchange.Transport.dll?

    Thursday, July 12, 2007 4:46 PM

    Even if that here is an older thread, I would like to continue, because its 100% the problem we have encountered.


    I can't connect (not even one) linux based SMTP Server. The error differs (depend on the target smtp server). This is an example with an (big) german provider.


    2007-09-07T15:46:20.015Z,wixe2,08C9BF7D5E82694D,0,,,*,,attempting to connect
    2007-09-07T15:46:20.093Z,wixe2,08C9BF7D5E82694D,2,,,<,220 smtp.1und1.de (mrelayeu7) Welcome to Nemesis ESMTP server,
    2007-09-07T15:46:20.093Z,wixe2,08C9BF7D5E82694D,3,,,>,EHLO server.fsn-XXX.de,
    2007-09-07T15:46:20.109Z,wixe2,08C9BF7D5E82694D,4,,,<,250-mrelayeu7.kundenserver.de pleased to meet you,
    2007-09-07T15:46:20.296Z,wixe2,08C9BF7D5E82694D,6,,,<,250-AUTH PLAIN LOGIN,
    2007-09-07T15:46:20.296Z,wixe2,08C9BF7D5E82694D,7,,,<,250-AUTH=PLAIN LOGIN,
    2007-09-07T15:46:20.296Z,wixe2,08C9BF7D5E82694D,9,,,<,250-SIZE 52428800,
    2007-09-07T15:46:20.296Z,wixe2,08C9BF7D5E82694D,10,,,<,250 HELP,
    2007-09-07T15:46:20.296Z,wixe2,08C9BF7D5E82694D,11,,,>,AUTH LOGIN,
    2007-09-07T15:46:20.312Z,wixe2,08C9BF7D5E82694D,12,,,<,334 <authentication information>,
    2007-09-07T15:46:20.312Z,wixe2,08C9BF7D5E82694D,13,,,>,<Binary Data>,
    2007-09-07T15:46:20.328Z,wixe2,08C9BF7D5E82694D,14,,,<,334 <authentication information>,
    2007-09-07T15:46:20.328Z,wixe2,08C9BF7D5E82694D,15,,,>,<Binary Data>,
    2007-09-07T15:46:20.343Z,wixe2,08C9BF7D5E82694D,16,,,<,235 authentication finished successfully,
    2007-09-07T15:46:20.343Z,wixe2,08C9BF7D5E82694D,17,,,*,2,sending message
    2007-09-07T15:46:20.343Z,wixe2,08C9BF7D5E82694D,18,,,>,MAIL FROM:<Administrator@fsn-XXXde> SIZE=7114,
    2007-09-07T15:46:20.343Z,wixe2,08C9BF7D5E82694D,19,,,>,RCPT TO:<kXXX@XXX.de>,
    2007-09-07T15:46:20.359Z,wixe2,08C9BF7D5E82694D,20,,,<,503 bad sequence of commands,
    2007-09-07T15:48:20.406Z,wixe2,08C9BF7D5E82694D,21,,,<,421 smtp.1und1.de connection timed out,
    2007-09-07T15:48:20.406Z,wixe2,08C9BF7D5E82694D,0,,,*,,attempting to connect



    I've tried at least 4-5 Providers, also I tried to connect a qmail server on our local lan - allway syntax errors.


    Annother sample


    2007-09-07T15:53:08.281Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,2,,,<,"220 dedi32.your-server.de ESMTP Exim 4.50 Fri, 07 Sep 2007 17:53:07 +0200",
    2007-09-07T15:53:08.281Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,3,,,>,EHLO server.fxxxxxxxxx.de,
    2007-09-07T15:53:08.296Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,4,,,<,250-dedi32.your-server.de Hello server.fsn-xxxxxmann.de [],
    2007-09-07T15:53:08.296Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,5,,,<,250-SIZE 31457280,
    2007-09-07T15:53:08.296Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,8,,,<,250-AUTH LOGIN PLAIN,
    2007-09-07T15:53:08.296Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,10,,,<,250 HELP,
    2007-09-07T15:53:08.296Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,11,,,>,AUTH LOGIN,
    2007-09-07T15:53:08.312Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,12,,,<,334 <authentication information>,
    2007-09-07T15:53:08.312Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,13,,,>,<Binary Data>,
    2007-09-07T15:53:08.328Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,14,,,<,334 <authentication information>,
    2007-09-07T15:53:08.328Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,15,,,>,<Binary Data>,
    2007-09-07T15:53:08.359Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,16,,,<,235 Authentication succeeded,
    2007-09-07T15:53:08.359Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,17,,,*,5,sending message
    2007-09-07T15:53:08.359Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,18,,,>,MAIL FROM:<Administrator@fsn-XXX.de> SIZE=7170,
    2007-09-07T15:53:08.359Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,19,,,>,RCPT TO:<kXXX@XXX.de>,
    2007-09-07T15:53:08.375Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,20,,,<,503 sender not yet given,
    2007-09-07T15:58:08.328Z,SMTP-Ausgang,08C9BF7E4FFDF6F7,21,,,<,421 dedi32.your-server.de: SMTP command timeout - closing connection,


    The connect is only succesfull with a windows based SMTP Server (here MDAEMON)


    007-09-07T16:01:48.265Z,sidgmbh,08C9BF7F87744A45,2,,,<,"220 sid-net.de ESMTP MDaemon 6.8.0; Fri, 07 Sep 2007 18:11:15 +0200",
    2007-09-07T16:01:48.265Z,sidgmbh,08C9BF7F87744A45,3,,,>,EHLO server.fsn-xxxxxxmann.de,
    2007-09-07T16:01:58.187Z,sidgmbh,08C9BF7F87744A45,4,,,<,"250-sid-net.de Hello server.fsn-xxxxxxmann.de, pleased to meet you",
    2007-09-07T16:01:58.437Z,sidgmbh,08C9BF7F87744A45,7,,,<,250-AUTH LOGIN CRAM-MD5,
    2007-09-07T16:01:58.437Z,sidgmbh,08C9BF7F87744A45,9,,,<,250 SIZE 0,
    2007-09-07T16:01:58.437Z,sidgmbh,08C9BF7F87744A45,10,,,*,2,sending message
    2007-09-07T16:01:58.437Z,sidgmbh,08C9BF7F87744A45,11,,,>,MAIL FROM:<XXXX@fsn-xxxxxxmann.de> SIZE=7211,
    2007-09-07T16:01:58.531Z,sidgmbh,08C9BF7F87744A45,12,,,<,"250 <XXXr@fsn-xxxxxxmann.de>, Sender ok",
    2007-09-07T16:01:58.531Z,sidgmbh,08C9BF7F87744A45,13,,,>,RCPT TO:<KXXX@web.de>,
    2007-09-07T16:01:58.625Z,sidgmbh,08C9BF7F87744A45,14,,,<,"250 <kXXX@web.de>, Recipient ok",
    2007-09-07T16:01:58.625Z,sidgmbh,08C9BF7F87744A45,16,,,<,"354 Enter mail, end with ""."" on a line by itself",
    2007-09-07T16:01:59.000Z,sidgmbh,08C9BF7F87744A45,17,,,<,"250 Ok, message saved <Message-ID: 8F00A3537ECC6C47B6F1D2AE446E4D7EA3D3AB34@server.fsn-xxxxxmann.de>",
    2007-09-07T16:01:59.109Z,sidgmbh,08C9BF7F87744A45,19,,,<,221 See ya in cyberspace,


    In my opinion the connector does not wait for an 250 after auth, this then results in an 500 error from the linux server.



    We already tried:


    Aktualisierungrollup1 für ExchangeServer 7.0

    Aktualisierungrollup2 für ExchangeServer 7.0

    Aktualisierungrollup3 für ExchangeServer 7.0

    Aktualisierungrollup4 für ExchangeServer 7.0


    Actually we have installed

    Aktualisierungrollup3 für ExchangeServer 7.0


    by the way: We can't deinstall "Aktualisierungrollup3 für ExchangeServer 7.0", cause it says that it hasn't been applied to the product ...... But it obviously had added new featuers (surface) to the managment tools (console et al)


    We have tried to change the properties of the connector using the command-line tool e.g

    IgnoreSTARTTLS cause we thought that this was the problem (support of one provider told us that we are trying to send with ssl).


    I looked for thar transport ....dll, where can I find it ?


    I did all what I can do, browsing the web and the technical documentation many hours - I lost more than one day with this "problem" - now I don't have any idea ....





    Friday, September 07, 2007 6:50 PM
  • Unbelivable but true: The solution is quite simple: Replace the network drivers. In our case it was Intel Pro 1000 Driver from 4/2006, Now we have a driver from 10/2006, all problems have gone.......


    Thursday, September 13, 2007 2:12 PM

    Thanks for letting us know Sidsup.


    We were just about to go and try repro this.




    Thursday, September 13, 2007 6:43 PM
  •  sidsup wrote:
    Unbelivable but true: The solution is quite simple: Replace the network drivers. In our case it was Intel Pro 1000 Driver from 4/2006, Now we have a driver from 10/2006, all problems have gone.......


    Well thanks a lot!! This sounds very traceable.  I'll have a look on the driver, cause it is the Intel Pro 1000 --- funny very funny.


    In the meantime I replaced the E12 through Exchange 2003, so the users could work, but asap I'll change it again again to E12.


    When the server is installed I'll give a review. Thanks sidsup!!

    Friday, September 14, 2007 6:22 AM
  • Use Exchange 2007 on VMWare Server 1.0.5  Win 2003 STA x64

    got exactly the same problems with sending mails and SMTP Error Code 503 (Bad sequence of commands, or Mail From: first...)

    also got it on another server before, then we decided to reinstall it on a virtual machine, it worked for 2-3 months, and now, the same...

    VMWare Network drivers also Intel Pro/1000 ...MT

    the latest drivers on intel page: Version 13.0 (but there was no Windows 2003 x64 driver version, so i used the Intel(R) Network Connections Software Version 12.4)

    AND NOW: the same problem...
    didn't work for me

    Any problems from exchange 2007 with using network adapters for his SNMP Commands or something like that?

    Tuesday, June 10, 2008 9:32 AM


    we have a similar problem with exchange server 2007 in a hyperV Machine with server 2003 64 Bit. Exchange is unable to deliver Email over a smarthost. We sniffed the traffic and we saw, that exchange sends the mail from: and rcpt to: message of the smtp protocol in one Packet. After that packet the smarthost gives an error 503 bad sequence of commans.

    If we simulate the same communication with telnet and the messages in different packages the communication is ok..

    Is there a possibility to tell exchange to send the two messages in different packages?

    Monday, October 20, 2008 4:13 PM