locked
Reset HTTP Redirect Settings Back to Defaults for /owa and /Exchange RRS feed

  • Question

  • After a clean install of Exchange 2010 on Server 2008 R2, I was trying to redirect people who went to http://oururl.com/owa to https://oururl.com/owa.  I changed the HTTP redirect setting for the "owa" folder in IIS to the https address.  This caused some problems so I wanted to set it back.

    The problem now is that any change I make to the HTTP redirect setting for the "owa" folder, also changes the setting for the "Exchange" folder (and vice versa).  By default the "Exchange" folder had an HTTP redirect to "/owa" and the "owa" folder had no redirect.  I want to restore the original "Exchange" redirect for users who are still using our old Outlook Web address (which was "/exchange" instead of "/owa")

    How do I make the "Exchange" directory have an HTTP redirect to "/owa" but not have it mirrored in the setting for the "owa" folder (because this breaks Outlook Web App)?  This was the original configuration.

    Thanks!

    Wednesday, May 25, 2011 10:07 PM

All replies

  • If you set HTTP redirect in the web site, you then have to go to each virtual directory underneath and clear the setting because it propagates but you don't want it on the virtual directories.  I know, it's a pain, but that's the way it is.

    Don't make /Exchange redirect to /OWA.  Actually, it should redirect there by default.  If you don't need /Exchange, remove that virtual directory with the Remove-OwaVirtualDirectory cmdlet, along with /Exchweb and /Public if you don't need them anymore.

     


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Wednesday, May 25, 2011 10:19 PM
  • Thanks for the response, Ed.  I had already found out about the HTTP redirect setting propagating to directories below, but this isn't the problem.  Maybe I can clarify with the following info...

    • You are right that /Exchange redirects to /owa by default and this is what I want restored.
    • Looking at a default/clean install of Exchange it appears it does this using the HTTP redirect feature. (/Exchange is set to redirect to /owa)
    • Also on a default/clean install the /owa directory does not have a redirect (and redirecting it to itself breaks stuff).
    • The /owa directory isn't below the /Exchange directory but whenever the HTTP redirect setting is changed on the /Exchange directory it also changes the setting on the /owa directory and vice versa.  So I can't find a way for each of these directories to have a unique HTTP redirect setting like they were configured by default.
    Hope this makes more sense.  Thanks again!
    Thursday, May 26, 2011 10:08 PM
  • You can delete the /Exchange virtual directory by using Remove-OwaVirtualDirectory and then add it back using New-OwaVirtualDirectory.  That should restore it with the default settings.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, May 27, 2011 12:05 AM
  • Hi,

    > So I can't find a way for each of these directories to have a unique HTTP redirect setting like they were configured by default.

    Because they have the same Physical  Path so you cannot make them have the different HTTP redirect setting.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by Jason LJS Friday, May 27, 2011 8:09 AM
    • Unproposed as answer by Jason LJS Friday, May 27, 2011 8:09 AM
    Friday, May 27, 2011 8:09 AM
  • But you could remove the Exchange virtual directory /Exchange (use PowerShell) and then create a new "regular" virtual directory that has a redirect.
    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Friday, May 27, 2011 2:09 PM
  • Hi... I also have the same problem... but removing and adding the virtual directory doesn't solve the problem. IS there any other solution for this problem... My platform is exchange 2010 sp3
    Saturday, August 9, 2014 9:29 PM