locked
Change location where word searches for unsaved files RRS feed

  • Question

  • We use word 2010 with win7/64. We use a mandatory profile. 

    With a grouppolicy we have changed the place where auto save/recover documents go to h:\word.

    That works. 

    Now when Word crashes, and I restart Word you get the recovered documents at startup.  

    But if the PC crashes, and the user restart the pc, there are no auto-saved documents. Well they are but Word doesn't find them because the registry key /resilency  is gone with the restart, because of the mandatory profile, makes that the user has a clean profile. 

    Now there is a nice button "Recover Unsaved documents" at the bottom of the recent list, that would help out, if it wasn't always pointing to the local userprofile 

    C:\Users\Username\AppData\Local\Microsoft\Office\UnsavedFiles

    There seems no way to change that location, from which one would expect that it would point to the same auto-save location, as where the documents go. 

    Another annoyance is that when from that I browse the the h:\word folder, Word won't open the .asd files. If I instead copy the file to C:\Users\Username\AppData\Local\Microsoft\Office\UnsavedFiles, then Word will open it fine.

    So to conclude: If the "Recover Unsaved documents" would point to the same dir as the autosave dir, and would open files there it is solved. 

    This is a problem for our 4500 workstations. 

     

    Tuesday, January 8, 2013 11:47 AM

All replies

  • Hi,

    This file location cannot be changed.

    We may consider the following workarounds:

    1. Copy the .asd files from h:\word to C:\Users\Username\AppData\Local\Microsoft\Office\UnsavedFiles by creating logon script.

    2. Redirect the folder.

    Best regards,


    Rex Zhang
    TechNet Community Support

    If you have any feedback on our support, please click here



    • Edited by Rex Zhang Wednesday, January 9, 2013 2:58 AM
    Wednesday, January 9, 2013 2:53 AM
  • Hi,

    Just checking in to see if the information was helpful. Please let us know if you would like further assistance.

    Best Regards, 


    If you have any feedback on our support, please click here


    Rex Zhang
    TechNet Community Support

    Friday, January 11, 2013 3:26 AM
  • Hi

    we are having a similar issue, however we have restricted access to the C:\ drive for std users.

    AS this path is on the C:\ drive, when we click 'Recover unsaved documents' our users are presented with:

    'This operation has been cancelled due to restrictions in effect on this computer'

    We have already redirected the autosave location via GPO. this location is still the users appdata/local folder.

    Surely this can be changed? Is MS telling me that if we restrict access to c:\, functions such as 'recover unsaved documents' are no longer available?

    Please let me know

    Regards,

    Max

    Tuesday, February 12, 2013 9:52 PM
  • Max,

    It looks like this is exactly what MS is telling us. We have the same problem on our Terminal Servers (2008R2 + Office 2010). Users can't see the C:\ drive and get the same error when they try to recover unsaved files.

    In our case the problem gets even bigger. We use Roaming Profiles and the AppData\Local part of the profile isn't roaming. So if a user logs off and logs on again, "it's gone!".

    I hope this will be fixed soon, but I doubt it. Nice feature, but useless in a controlled enviroment.

    Bas

    Tuesday, September 17, 2013 2:24 PM
  • Running Citrix in an environment similar to Max and have the same problem.  We mapped the AutoSave folder to a central file server so that the files themselves aren't lost.  I searched the registry and didn't find the path there ... it just seems senseless to hard-code this on just the "Recover Unsaved Documents" part of the equation.
    Tuesday, December 31, 2013 4:10 PM
  • Important: These file locations cannot be changed.


    blogs.msdn.com /b/mssmallbiz/archive/2012/04/20/how-to-recover-that-un-saved-microsoft-office-excel-word-or-powerpoint-file-you-closed-before-saving.aspx
    Wednesday, January 15, 2014 3:05 PM
  • It does seem like a massive oversight that this wonderful feature is not available to those who are using RDS servers and have them locked down, any chance of an update to allow this MS?


    • Edited by Jason R UK Friday, December 4, 2015 3:43 PM
    Friday, December 4, 2015 3:42 PM
  • Running into this with Server 2012 R2, Office 365 (2016) with Shared Activation. I am guessing nobody has a solution to this problem? It's frustrating as the auto-recover files are actually saved on the share, it's just Explorer trying to access C:\Users\%username%\AppData\Local\Microsoft\Office\UnsavedFiles that causes the problem.


    Shaun

    Friday, April 8, 2016 2:25 PM