none
FAST4SP - Deep refiner show's wrong count after using the refinement RRS feed

  • Question

  • Hi All,

    We've been running through a really strange behavior using refinement panel with (item) counters against FAST4SP.

    We have SharePoint 2010 SP1 + February 2012CU and FAST Search for SharePoint 2010 SP1.

    We have configured a Managed Property with "Deep Refiner" checkbox selected called "owsmayorlevel1refinement".



    Managed Property configuration:

    

    After mapping and configuring the above property, we ran full crawl.

    We also configured the search refinement panel to query for the specific property and show item counts.

    Here is the Filter Category configuration for the web part: (settings mentioned above are BOLD below)

             

    <Category
       Title="Level 1" 
       Description=""    
       Type="TlvArchive.Mayor.Webparts.MultiValueFilterGenerator, TlvArchive.Mayor.Webparts, Version=1.0.0.0, Culture=neutral, PublicKeyToken=0b35e34dcb80d925"
       MetadataThreshold="1"       
       NumberOfFiltersToDisplay="3"     
       SortByForMoreFilters="NumericValue"        
       SortDirectionForMoreFilters="Ascending"      
       SortBy="NumericValue"            
       SortDirection="Ascending"          
       MaxNumberOfFilters="250"       
       FASTMaxNumberOfFilters="10000"   
       ShowMoreLink="True"           
    MappedProperty="owsmayorlevel1refinement"
       MoreLinkText="Show more"          
       LessLinkText="Show less"           
    ShowCounts="Count" />



    After investigating this issue we suspect the reason is that SharePoint somehow uses its "Shallow Refinement" instead of FAST's "Deep Refinement" as we configured the managed property to be.

    The strange thing is that it works perfectly in our Dev and testing environments but not on our Pre-production and Production environments.

    We tried playing with the "Use default configuration" checkbox and the "Accuracy Index" of the refienement panel web part.
    We saw that while using the "Accuracy Index" (changed to 500) it showed better results but not still not exact results.
    We also tried querying directly search.asmx (FAST web service) and we saw that Counts were accurate.
    That's why we suspect that the issue is with SharePoint and not FAST.

    *Sorry for editing the text in the attached screenshots (Security)

    Thank you all :)

    Sunday, June 28, 2015 12:59 PM

All replies

  • Here's an example of the issue:

    Count before filtering by above managed property:

    Count after filtering by above managed property:

    Sunday, June 28, 2015 1:00 PM
  • Bumping it up again.

    Anyone with idea how to resolve this?

    Thanks,
    Guy

    Tuesday, July 14, 2015 7:09 AM