none
Need help with error: "a virtual machine resource was not found in a clustered virtual machine . . ."

    Question

  • Hello,

    This is a crosspost  from over on the High Availability (Clustering) forum, but with some updates. 

    Howdy folks,

    I run a 3 node cluster using Server 2012 R2 for our virtualization environment, which includes SCVMM 2012R2.  
    For two VM's I'm getting the Failover Cluster Manager error  "A virtual machine resource was not found in clustered virtual machine '<vmname> Resources", and in SCVMM I get "Unsupported Cluster Configuration". 
    I have 25 other vms on the same setup without issues, some of which on the same host.

    This problem popped up a couple weeks ago and I resolved it for one of the vm's by deleting it (but kept its vhds), then just recreated it using the same vhds. That seemed to work, but it just happened again to the same vm.  The VM's it's happening to have been running without issue for a few years until now.

    This seemed like it could be a permissions issue, and upon inspection I saw that the vhdx's were missing permissions for the "virtual machines" group which is present on all other vhdx's.  So, I dug around and found a way to reset permissions on all the files and folders for these vms.  The permissions look correct now, but that didnt help. I still get the same errors.  FYI, if you're looking for how to reset permissions on VM disks and files, here's a good article with script for doing just that:
    https://blog.mikejmcguire.com/2013/10/14/wipe-them-out-all-of-them-restoring-all-lost-hyper-v-permissions/

    Continuing on, I found when viewing through the Failover Cluster Manager console and selecting the VM's at hand, the Resources pane at the bottom is empty (as expected from the error . . . ie, no resources could be found).

    I then ran a cluster validation.  The report shows the warning "The group does not contain any resources" for the affected VMs.

    Whereas for all others it shows "Dependency: The 'SCVMM <vmname>' resource depends on the 'SCVMM <vmname> Configuration' resource'.

    Following up on that, I decided to try this powershell command to update the cluster:

    Get-VM "<vmname>" | Update-ClusterVirtualMachineConfiguration

    this returned

    Update-ClusterVirtualMachineConfiguration : Cannot find the virtual machine represented by ID 7218453d-b14c-4932-966b-8b1c0c611076.

    Seeking more information on what could be causing this, I discovered this article "Error “The cluster group could not be found” in Virtual Machine Manager" which can be found here:
    http://www.server-talk.eu/wp-content/uploads/article_2010-08-14_VMM-EN.pdf

    Whereas the issue resolved in that article is a mismatch between the data in the registry and database for the VMResourceGroupID guid, my issue differs.

    In my case, the VMResourceGroupID and the ID set for that parameter in the registry do match up, however, the registry is missing the guids in HKLM\Cluster\Groups\<VMResourceGroupIDGuid>.  Here, the "Contains" reg_multi_sz is empty. This should contain two guids which ultimately point to the VM's ID and configuration information within the registry.  Hence, the errors I get since this information is missing.

    So, I just chased my tail back to the starting point, but at least I see where the issue stems from.

    Has anyone seen this issue before? Any idea on how to fix it? 

    Sunday, October 29, 2017 7:06 PM

All replies