SBS2011, Need to rebuild WSUS, IIS, Internal Database, Companyweb


  • HI

    I discovered, after installing Quickbooks multi-user on SBS 2011, why Quickbooks is not supported on SBS. They dont mention it on the Intuit website, however Quickbooks installs the .NET framework 1.1 which destroys all existing SBS 2011 web applications. In working through a lot of forum posts, permissions issues etc, nothing was working. It was not until IIS was a total train wreck that I found a forum post about Quickbooks killing SBS IIS. The solution they took was a full rebuild from scratch of SBS. I dont have this luxury and need to re-install the internal database, WSUS and companyweb from scratch on a live SBS installation.

    I plan to follow the rough guide here, to attempt to repair everything however this is specifically for SBS2008 but I think it is still directly relevant. Once I do this, I will try to reinstall WSUS 3 SP2 and see how it goes.

    Does anyone have experience with this kind of issue and/or any suggestions or things to be aware of that might cause grief?

    Any help appreciated.



    Saturday, June 16, 2012 6:36 AM


All replies

  • QB 2012 installs .net 4 and seems to work fine on SBS 2012 if you only install the server portion. You must be using an older version of QB?


    Saturday, June 16, 2012 7:08 AM
  • Hi

    I thought it was 2012-13, the latest version (Australia). It definitely installed .NET 1.1, I watched it do it. I only installed the server components. Quickbooks is running fine, I just need asstance rebuilding all the web apps that were blown up by installing .NET 1.1 on SBS 2011.


    Saturday, June 16, 2012 7:12 AM
  • Any help here?
    Merv  Porter   [SBS-MVP]
    Saturday, June 16, 2012 1:49 PM
  • Also from Susan with link to Intuit stating QB 2012 is natively installed and supported on SBS 2011. Notice that QB 2012 installs .net 4 not 1.1 (which does break everything) so not sure why it did that on your install.


    Saturday, June 16, 2012 8:28 PM
  • Her link:

    "Compukirk" <> wrote in message

    Also from Susan with link to Intuit stating QB 2012 is natively installed and supported on SBS 2011. Notice that QB 2012 installs .net 4 not 1.1 (which does break everything) so not sure why it did that on your install.


    Saturday, June 16, 2012 8:38 PM
  • Apparently Quickbooks for Australia is still .NET 1.1, even the latest version.

    A knowledgebase article was published 4 days after I blew up this server about it (I am only just getting back to sorting it properly). They had steps to rectify the damage QB and .NET 1.1 caused if it was installed but it was too late for me, I had already tried heaps to get it working and have only ended up breaking it further.

    Basically, we need to ignore the fact that Quickbooks caused the problem and I need to restore WSUS and Companyweb functionality to SBS 2011 caused by a .NET 1.1 installation while maintaining .NET 1.1 for QB.

    The Windows internal DB appears to be OK, an installation of WSUS 3 SP2 gave me the option to remove it and keep the database and files which I did then it was reinstalled. It was pointed to the internal DB and saw it, checked it and successfully connected to it but the WSUS site (and WSUS management) still cannot be connected to. I have re-registered .NET 2 and 4 as per Merv's link (I had found that article before and tried the steps, also to no avail) and after trying to browse to the WSUS site in IIS and getting an ISAPI error, have allowed .NET 1.1 in ISAPI in IIS, but it still does not work.

    If I cannot get Companyweb working, it is no big deal, the client does not use it but I need WSUS working. I have changed the GPO to get updates directly as a workaround but dont like having a server in place with broken components, they tend to remain problematic for the life of the server.



    Sunday, June 17, 2012 2:40 AM
  • Ben,

    Here's the docs for SBS 2011 and Companyweb:

    Repair SharePoint Foundation 2010 -

    Reinstall SharePoint Foundation 2010 -

    Thanks Robert Crane [MVP-Office365]

    Wednesday, June 20, 2012 12:49 AM
  • Thanks Robert

    I will give this ago just as soon as the client pays me my outstanding invoices for the hardware and see how I go.



    Wednesday, June 20, 2012 10:48 AM
  • I am having a similar issue as the OP after installing Quickbooks 2011/12 (Australian version) onto an SBS 2011 box!

    Everything appears to be working (including QB) but as per this thread all off the internal web stuff has stopped working!

    After hours of trying things including removing and installing Sharepoint it still isn't working.....

    When I was setting up Sharepoint it wouldn't let me use the same name for the database (as per ms doc) as it was already on the server! I even tried creating a one with a different name but at the end of the process I went into Sharepoint and it wanted to run the wizard again......  How do you remove the old databases? I am really at a loss to get this working again!

    I did notice on a pc before I left went to the IIS7 screen when accessing the companyweb page, previous to the above it didn't do anything apart from a 500.0 error!

    cheers,  Scott

    • Edited by i.t.gadgets Wednesday, October 17, 2012 12:37 PM
    Wednesday, October 17, 2012 12:22 PM
  • Have you seen Susan's Blog about this?  (includes a couple of potential fixes)

    Merv  Porter   [SBS-MVP]
    Wednesday, October 17, 2012 1:39 PM
  • Have you seen Susan's Blog about this?  (includes a couple of potential fixes)

    Merv  Porter   [SBS-MVP]

    Thanks for the reply but yes I have and nothing worked, unless I did something wrong! The guy at Quickbooks support sent me something similar to try as well!

    I am worried that all of my trying to fix things has done something that can't be fixed!

    Wednesday, October 17, 2012 7:13 PM
  • Hi Scott

    I ended up using a PSS call and was on the phone with support for about 6 hours. I lost track of exactly what they did to get it operational again.

    It sounds like you did exactly what I did and tried to fix it and ended up killing it badly.

    Here is what I got back from Microsoft after they fixed it:

    It was my pleasure to work with you on the Unable to browse CompanyWeb issue. I hope that you were delighted with the service provided to you. I am providing you with a summary of the key points of the case for your records. If you have any questions about this issue please feel free to call me. My contact information is below.
    Based on our last conversation, it appears that this case is ready to be closed. If this is premature or you are not satisfied with all aspects of this case 112091419313775, please let me know as soon as possible. Otherwise, I will close this case at the close of business today. Thank you for choosing Microsoft.
    PROBLEM: Unable to browse CompanyWeb
    Changed .net version for following App POOLS from 4.0 to 2.0
    1) Classic .net APP_POOL
    2) Default APP-POOL
    3) <GUID> APP_POOL
    4) Central Admin app pool
    5) SecurityToken App pool

    Removed Following exception from web.config
    <section name="scriptResourceHandler" type="System.Web.Configuration.ScriptingScriptResourceHandlerSection, System.Web.Extensions, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35" requirePermission="false" allowDefinition="MachineToApplication" />
    Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35">
            <sectionGroup name="webServices" type="System.Web.Configuration.ScriptingWebServicesSectionGroup, System.Web.Extensions,

    Created new FARM
    Extended website

    removed WSUS
    reinstalled WSUS



    Hope this helps, if you do raise a suport ticket, give them my reference number as a starting point, might save some time.



    Sunday, October 21, 2012 10:30 AM