none
Indexer partition full, memory limit reached RRS feed

  • Question

  • Hi,

    After index 6 million rows I'm getting this message:

    percentage_file_distributor: Partition 0 is full: Memory limit reached. 

    Is this a indexer queue size issue?


    Tuesday, April 17, 2012 2:57 PM

Answers

  • It looks like you are trying to index more documents than your installation can handle. Most likely you will either need to add another column or simplify your index profile.

    You are getting the following error message: "Info percentage_file_distributor : Partition 2 is full : Memorylimitreached." Data index full messages is a problem which indicates that you cannot index more docs into that partition. Number of docs in partition is mainly configured using docDistributionmax parameter and docDistributionmaxMB parameter. Out of these docdistribtionmaxMB parameter specifies the amount memory used while a particular partition is getting indexed. If this memorylimit is reached before doc count gets to the value specified by the docdistributiobmax parameter partition is marked as full.

    docsDistributionMaxMB will limit the amount of documents in a single partition, based on the memory used by the indexing and search processes. 
    The indexer measures how much memory is used per document during indexing and search, on average. 
    This value is then used to calculate a maximum number of documents per partition, based on the configured max MB limit set by this parameter. 
    For example, setting this parameter to 1000, will limit each partition to max 1000 MB. 
    If search uses 1000 bytes per document, this will limit the number of documents to 1 million. 
    When the limit is reached for all partitions, no more documents will be indexed.
    
    In default configuration, above is limited to 1GB. You need to increase this accordingly of allowing more documents.
    Setting it to quite a bit lower than 2GB is recommended to leave room for fsearch caches, etc.
    it will not allow the indexer to create too large partitions. 

    Wednesday, April 18, 2012 5:03 PM
  • Hello Rogério

    I would also recommend reviewing the following KB.  It provides a very good overview.
    How to configure indexer partitions for FAST ESP

    http://support.microsoft.com/kb/2523632

    Best Wishes,

    Michael Puangco | Senior Support Escalation Engineer | US Customer Service & Support

    Customer Service & Support                        Microsoft| Services

    Customer Service & Support                        Microsoft| Services

    Customer Service & Support                        Microsoft| Services

    Tuesday, April 24, 2012 3:14 PM
    Moderator

All replies

  • It looks like you are trying to index more documents than your installation can handle. Most likely you will either need to add another column or simplify your index profile.

    You are getting the following error message: "Info percentage_file_distributor : Partition 2 is full : Memorylimitreached." Data index full messages is a problem which indicates that you cannot index more docs into that partition. Number of docs in partition is mainly configured using docDistributionmax parameter and docDistributionmaxMB parameter. Out of these docdistribtionmaxMB parameter specifies the amount memory used while a particular partition is getting indexed. If this memorylimit is reached before doc count gets to the value specified by the docdistributiobmax parameter partition is marked as full.

    docsDistributionMaxMB will limit the amount of documents in a single partition, based on the memory used by the indexing and search processes. 
    The indexer measures how much memory is used per document during indexing and search, on average. 
    This value is then used to calculate a maximum number of documents per partition, based on the configured max MB limit set by this parameter. 
    For example, setting this parameter to 1000, will limit each partition to max 1000 MB. 
    If search uses 1000 bytes per document, this will limit the number of documents to 1 million. 
    When the limit is reached for all partitions, no more documents will be indexed.
    
    In default configuration, above is limited to 1GB. You need to increase this accordingly of allowing more documents.
    Setting it to quite a bit lower than 2GB is recommended to leave room for fsearch caches, etc.
    it will not allow the indexer to create too large partitions. 

    Wednesday, April 18, 2012 5:03 PM
  • Hello Rogério

    I would also recommend reviewing the following KB.  It provides a very good overview.
    How to configure indexer partitions for FAST ESP

    http://support.microsoft.com/kb/2523632

    Best Wishes,

    Michael Puangco | Senior Support Escalation Engineer | US Customer Service & Support

    Customer Service & Support                        Microsoft| Services

    Customer Service & Support                        Microsoft| Services

    Customer Service & Support                        Microsoft| Services

    Tuesday, April 24, 2012 3:14 PM
    Moderator
  • Hi,

    I have the same problem. My server is 64-bits, its meaning it can be address 4GB. So, Can I setting my docsDistributionMaxMB to 4GB or it can be at most to 2GB ?

    Another question is : Are there some problem about this change in docsDistributionMaxMB about the documents indexed ? Can I change without any problem in my partition are full ?

    Thanks,

    Marcio Nobrega

    Wednesday, August 29, 2012 7:18 PM