none
workgroup computer no longer backing up, agent will not connect RRS feed

  • Question

  • Hi,

    I have a workgroup computer that I cannot authenticate on DPM anymore.

    I have gone through everything I can think of to fix but it is not working.

    I have:

    ran the setdpmserver command on protected compute, tried attaching the agent via the install agent screen.

    manually reset the user passwords on both dpm and protected machine

    ran update-nondomainserverinfo.ps1 on DPM server.

    deleted and created new user accounts on both servers and ran the above scripts with new account details

    I have even uninstalled the agent on protected machine and reinstalled the agent and done all of the above again.

    Nothing is working

    I get this error all the time

    Protection agent version: 4.2.1373.0

    Error: Data Protection Manager Error ID: 318
    The agent operation failed because DPM was unable to identify the computer account for <servername>.
    Detailed error code: No mapping between account names and security IDs was done
    Recommended action: Verify that both <servername> and the domain controller are responding. Then in Microsoft Management Console (MMC), open the Group Policy Object Editor snap-in for the local computer and verify the local DNS client settings in Local Computer Policy\Computer Configuration\Administrative Templates\Network\DNS Client.


    Does anyone have any ideas what else I can do?

    Is there a way i can force DPM to forget about the protected workgroup computer and start again with it?

    Thursday, November 24, 2016 2:18 PM

All replies

  • 30 mins later and it's started working now without me doing anything else.

    frustrating but at least it is working :)

    Thursday, November 24, 2016 2:56 PM
  • Hi drensta,

    If it was working before and nothing is changed my first guess would be that the passwords are expired.

    You could have tried:

    SetDpmServer.exe -dpmServerName <serverName> -isNonDomainServer -updatePassword

    If you dont want to update the password once in a while you could enable the option:

    Password never expires on both: the local user account on the dpm server and the same local user account on the protected computer.

    If it was working after half an hour, could it be that there was a mismatch between the passwords on the dpm local user account and the protected computer local account and therefore the wrong password caused an Account Lock ?

    Friday, November 25, 2016 1:03 PM