none
Project Centre Webpart is not opening in project server 2010 RRS feed

  • Question

  • Hi ,

    I restored Publish , Draft, ARchive and Reporting database from our test server to production server.

    All data moved to production server but when i am trying to open project centre its giving an error .

    Can anyone help me on this .

    I tried to restore content database but after restoring the PWA site is not opening at all

    Regards

    Muhammed

    Sunday, July 7, 2013 6:40 AM

All replies

  • Hi,

    What do the logs say? Event viewer, ULS logs? 

    Also try to check the properties of the webapplication and see if they don't contain test server information.

    Try the following:

    $Web = get-SPWeb http://<servername>/<PWAInstance>

    $Web.AllProperties | Format-Table

    Check if the information gives you the PWAURL you are expecting. If not you need to update it.

    $Web.AllProperties[“PWAURL”]=””

    $Web.Update()

    Hope it helps.

    With kind regards,

    Robin Kruithof


    Technical Consultant EPM

    Sunday, July 7, 2013 11:31 AM
  • Hi Robin,

    Thank you for reply .

    I apply this also but still is not opening .

    I restored four database and tried to PWA provisioning its giving the following error.

    "Provisioning 'PWA': Failed to provision databases. An exception occurred: Published database schema version 14.1.252.0 newer than project server schema version 14.1.104.0."

    Regards

    muhammed

    Sunday, July 7, 2013 11:46 AM
  • Hi Muhammed,

    From the error, it looks like the environment in which the DB's are being restored is at a lower version then compared to the farm from which the DB's were backed up.

    I would suggest you to install the Service Pack or the Cumulative Update on this farm as well and then try provisioning the PWA.

    Regards,

    Dinesh Rai


    Cheers. Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management

    Sunday, July 7, 2013 5:44 PM
    Moderator
  • Hi Dinesh,

    Thank you for your answer.

    I installed CU and patches in Production server same as the test server.

    Now the PWA provisioned successfully but i got another issue that when i tried to create new project the project centre occures "An Unknown Error".

    I applied hotfix for resolving this issue but the result is same.

    Project centre giving "An Unknown error"

    regards

    Muhammed

    Monday, July 22, 2013 7:18 AM
  • Is this a custom EPT? Can you try creating the project using an OOB template.


    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.


    Thursday, August 22, 2013 10:00 PM
    Moderator
  • Did you use all 5 databases in the final working provision?  If not then the error may be due to missing PDPs as these are in the Content DB.  I'd suggest getting a 5 DB restore and provision working - or if you have not created new EPT's then you could just edit the existing ones to ensure the pages are referenced correctly.  Unknown error is very generic - check the ULS logs for the specific error - just applying a hotfix that happened to resolve a very specific 'unknown error' is very unlikely to fix anything else.

    Best regards,

    Brian.


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Friday, August 23, 2013 9:31 PM
    Owner