locked
schema update failure for exchange 2010 RRS feed

  • Question

  • I am having windows 2003 standard 64 bit edition DC with the forest wide FSMO roles in it ( I have single domain with multiple DC's all are having 2003 standard 64 bit edition OS) and Domain wide FSMO roles in other DC's with exchange 2007 installed on the exchange server

    As part of upgrade to exchange 2010 while performing schema upgrade on the DC with the command setup /PrepareSchema which was having Schema Master FSMO with Schema Admins security group and Enterprise Admins rights i was getting the error as mentioned below

    Error Details : This application has failed to start because wer.dll was not found.Reinstalling the application may fix the problem

    I dont have any 2008 DC to try the prepareschema command, please help me to resole this issue

    Monday, September 24, 2012 6:59 AM

All replies

  • Hi

    Have you already built one of the servers that you are going to use for Exchange 2010?  You could install the AD Directory Services role on that server (RSAT-ADDS) and run the schema update from there.

    Cheers, Steve

    Monday, September 24, 2012 8:25 AM
  • I have not identified the server so far for exchange  installation, please provide if any alternate option is available to upgrade using my 2003 DC
    Monday, September 24, 2012 8:35 AM
  • It seems you ID doesn't have Schema level rights. You need to add you self to Schema Admin and Enterprise

    Admin Group. Then only you can extend the Schema. You need to run this from DC which holds the Schema role.

    You must install Exchange 2010 on Server 2008 SP2 or Server 2008 R2 (Standard or Enterprise, not Datacenter).

    Check this link.

    http://technet.microsoft.com/en-us/library/bb124350.aspx

    http://technet.microsoft.com/en-us/library/bb125224.aspx

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/442371dc-d12c-4de4-a70b-25c5ab38935f


    ExchangeGeek (MCITP,Enterprise Messaging Administrator)

    ***Don't forget to mark helpful or answer***


    Monday, September 24, 2012 11:41 AM
  • Hi Sunil

    What windows server version are you installing exchange on? You need to install Exchange 2010 on Windows 2008 SP2 or higher. I see the account you installing with has Schema and Enterprise admins rights.

    You can also look here:

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/442371dc-d12c-4de4-a70b-25c5ab38935f

    Monday, September 24, 2012 1:06 PM
  • HI Steve,

    Thanks for the info, i am having another stand by member server in the domain with 2008 R2 version. please confirm whether i can use that server for schema upgrade

    If that server can be used whether it is mandatory to install RSAT-ADDS on the server, As it is some application server in the domain i dont want to use that for any other purpose

    waiting for your reply

    Monday, September 24, 2012 4:41 PM
  • http://technet.microsoft.com/en-us/library/bb125224.aspx

    http://blogs.technet.com/b/vytas/archive/2010/06/30/updating-schema-and-preparing-ad-for-exchange-2010.aspx

    http://msexchangeguru.com/2011/08/26/schema-update/

    Hope this helps.


    ExchangeGeek (MCITP,Enterprise Messaging Administrator)

    ***Don't forget to mark helpful or answer***

    Monday, September 24, 2012 5:15 PM
  • Hi Sunil,

    Check the below blog:

    http://networkadminkb.com/KB/a254/how-to-extend-the-schema-for-exchange-2010.aspx


    ***Don't forget to mark helpful or answer***

    Monday, September 24, 2012 7:55 PM