none
Unable to Process your Request RRS feed

  • Question

  • Hi,

    We have 2 instances of FIM (Portal+Service) installed in our QA environment. One for Admin and other for User. Now when I place a request in FIM to add a user to group, it places request successfully. End user is able to approve the request as well.

    Now we have a PowerShell script to add users to group and when that is used, requests get placed successfully but Approver is unable to approve the request. When he tries to submit the request he gets a pop up stating "Unable to Process the request". This only happens when request is placed via PowerShell.

    The difference I see between both request i.e. request raised directly and request raised via script is that the "Create Approval" request created in FIM has 2 different end point address referred. PowerShell uses Admin instance of fim portal and normal request has end point address as User Instance. PowerShell script does not have any reference to end point address so I am not sure why the differentiation is happening.

    I checked for many other blogs regarding this issue and checked all config. Everything looks perfect. I do not see any logs logged in event viewer as well. The only error I get at the end of PS script execution is as below:

    Unknown exception occurred when processing SOAP message from FIM. View the FIM error and debug logs for trouble shooting information.

    The same Powershell code works good in DEV environment and we are able to approve requests there.

    I have spent 2 full days in solving this but of no success. Can someone help me here?

    Thanks,


    Veena

    Thursday, August 18, 2016 8:10 AM

All replies

  • Veena-

    This is expected. The endpoint is stamped on the approval request. Specifically, the externalHostName value on the FIM Service instance is stamped there. If that endpoint isn't reachable by the server you try to make the request against, it will fail (which is what you're seeing).


    Thanks,
    Brian

    Consulting | Blog | AD Book

    Thursday, August 18, 2016 11:45 PM
    Moderator
  • Hi Brian,

    Thanks for your response. As you said we did not have access to the admin instance of the portal. So I updated the "externalHostName" to user instance in ADMIN Portal server. After this I was able to approve the reqeusts.

    Thanks,


    Veena

    Monday, August 22, 2016 5:28 AM