none
Controlling CD/DVD over Remote Desktop Connection RRS feed

  • Question

  • Hello,
    I cannot play CD audio when connected over Remote Desktop Connection. (I have selected play the audio on remote computer.)
    I even cannot eject the drive, MCI reports "Unknown problem while loading device driver." and if I right-click the drive in Windows Explorer and select Eject, it says the drive is currently in use.

    How can I control CD playback and drive over RDC?
    Thanks!
    Jan
    Friday, June 5, 2009 1:40 PM

Answers

  • You need to edit the Group Policy and enable a Computer Policy on the host computer with the CD/BD ROM.

    In the local Group Policy editor, go into Computer Configuration/Administrative Templates/System/Removable Storage Access

    Enable the policy "All Removable Storage: Allow direct access in remote sessions"

    This policy setting grants normal users direct access to removable storage devices in remote sessions.

    If you enable this policy setting, remote users will be able to open direct handles to removable storage devices in remote sessions.

    If you disable or do not configure this policy setting, remote users will not be able to open direct handles to removable storage devices in remote sessions.

    • Proposed as answer by Geedoubleu-uk Saturday, March 13, 2010 7:14 PM
    • Marked as answer by Jan Kučera Saturday, April 28, 2012 3:23 PM
    Saturday, March 13, 2010 7:14 PM

All replies

  • Jan,

    Try the solution listed in this thread and let us know...
    Saturday, June 6, 2009 2:41 AM
    Answerer
  • Hi dwolters,
    thanks for reply. I'm quite not sure what solution are you refering to, neither I think the thread is much releated.

    All other audio playback works, just the CD audio does not. It stops when I connect, and it works again when I disconnect (have to restart it, files are marked with red cross in WMP). Other sounds and playback from HDD works as expected even during RDC session.

    I am also able to see the cda files in Windows Explorer. I do not use Windows Media Center, only Windows Media Player or MCI commands.
    Hope this helps to clarify the scenario... should I check anything else, let me know.

    Jan
    Saturday, June 6, 2009 5:57 PM
  • Jan Kucera,

    This sounds like it may simply be a side effect of the legacy architecture that is used for CD audio on modern PCs. Try as I might, I can't seem to find much documentation of this - have you ever tried to listen to CD audio over a Remote Desktop connection on an older version of Windows?

    -Alex
    Saturday, June 6, 2009 11:54 PM
  • Alex,
    no, in fact this was the first time I tried to play audio CD or control the drive over remote desktop. Okay, I can accept that CD audio playback uses legacy architecture and, although I don't see any idea why, it might not work over RDC.

    However what I still don't get is that I cannoct eject the CD/DVD driver, regardless of what's inside...

    Jan

    Sunday, June 7, 2009 10:18 AM
  • Jan,

    You say you're able to browse the media files as normal over RDC using Windows Explorer - are you able to, say, open an executable or view an image?

    If not, I could see how not being able to eject the disc is an intended limitation of RDC, albeit with an unsuitable error prompt.
    -Alex
    Sunday, June 7, 2009 3:46 PM
  • I am having this same exact issue. I have a headless hi-fi music server set up and cannot read Audio CDs when connected via Remote Desktop (although over UltraVNC it works fine). I can play DVDs but many applications do not recognize the drive and are therefore unusable (for example Clone DVD and the firmware updater for my drive).
    Sunday, July 19, 2009 4:18 AM
  • Update: I changed the drive to a new blu-ray drive and have the same problem now with Blu-ray disks.
    Wednesday, July 22, 2009 12:08 PM
  • You need to edit the Group Policy and enable a Computer Policy on the host computer with the CD/BD ROM.

    In the local Group Policy editor, go into Computer Configuration/Administrative Templates/System/Removable Storage Access

    Enable the policy "All Removable Storage: Allow direct access in remote sessions"

    This policy setting grants normal users direct access to removable storage devices in remote sessions.

    If you enable this policy setting, remote users will be able to open direct handles to removable storage devices in remote sessions.

    If you disable or do not configure this policy setting, remote users will not be able to open direct handles to removable storage devices in remote sessions.

    • Proposed as answer by Geedoubleu-uk Saturday, March 13, 2010 7:14 PM
    • Marked as answer by Jan Kučera Saturday, April 28, 2012 3:23 PM
    Saturday, March 13, 2010 7:14 PM
  • Geedoubleu-uk

    thanks so much... that worked for me!

    • Proposed as answer by JulesLondon Saturday, April 28, 2012 2:28 PM
    • Unproposed as answer by Jan Kučera Saturday, April 28, 2012 3:23 PM
    Saturday, April 28, 2012 2:27 PM
  • Old thread, but this worked like a charm on a Windows 7 Ultimate HTPC. Thank you!
    Thursday, July 4, 2013 9:21 PM
  • Worked for me too under RDP Windows 10!

    Thanks

    Tuesday, July 2, 2019 7:39 PM