locked
Steady State on XP SP3 Internet restriction not working. RRS feed

  • Question

  • Hi all,
    I needed to set up a computer that was only allowed to go to certain websites that I specified.  When I ran across windows steady state I thought it would be perfect for the job.  Unfortunately, it doesn't seem to be working.  I have an XP machine using SP3.  I installed steady state and used it's interface to add a new user which I named User.  From there I went to feature restrictions and checked the "Prevent Internet access (except Web sites below)" option.  I've tried with others but also tested with *.msdn.com as the home page and web addresses allowed.  The trouble I have is that when I log in as that user it will try to load the page for a brief second and then I will receive the "Internet Explorer cannot display the webpage".  I can notice at the bottom for a brief second that it says something like "res://ieframe.dll/dnserror.htm" before changing to the word "Done".  I am using a static ip address while specifying a working DNS server that we use for all of our computers.  The DNS ip addresses are 198.6.1.4 and 4.2.2.3 

    Any ideas as to how to fix this?  It seems like the application is exactly what I'm looking for if I can just get it working.

    Many thanks
    Monday, August 25, 2008 1:58 PM

All replies

  •  

    Hi, have you set up proxy server on the network ? Please understand that SteadyState is designed for environment without proxy server.

    Wednesday, August 27, 2008 7:24 AM
  • As fas as I know we don't have a proxy server set up.  There is a sonicwall router set up as the gateway to the internet but no proxy server that I'm aware of.  I can also turn the internet site restriction off and can access all sites just fine.
    Wednesday, August 27, 2008 1:13 PM
  •  

    I am having the exact same problem. I installed Steady State in a classroom. I want to restrict access to only specific class related websites.

     

    Yet, the moment i turn on the restriction, i cannot get ANY website to display at all. Homepage. Allowed list. Nothing.

     

    And i see the same thing he's seeing. A moment when it seems the page will load, then an error message and it says done.

    Tuesday, September 16, 2008 3:58 PM
  • I have just installed it as well and am having exactly the same problem. Seeing that this is a fairly basic function you would expect thet the QA guys would have checked that this worked.

     

    Friday, September 19, 2008 6:09 AM
  • Ya that's what I would figure.  The only answers people seem to get are when they say it won't work if you're using a proxy.  I'd say the majority of people aren't using proxies.  Everything else about it seemed nice though, but I had to buy some other software since I couldn't get this to work.  If you are looking for something similar, you can try a google search for Kiosk software.  That's how I ended up finding something that would work for us.

    Good Luck all, hopefully they will get this fixed sometime soon.
    Friday, September 19, 2008 1:36 PM
  •  

    I'm getting the same problem, too bad I wanted to deploy this to about 1,000 Kiosk with this, starting with 100 in January.

     

    Looking into Linux distros now, since its just a web browser I need.

    Wednesday, December 10, 2008 3:42 PM
  • I'm having the same problem as well, on an XP SP3 machine. No proxy, the homepage won't load, nor any of the "allowed" sites.
    Friday, December 12, 2008 4:19 PM
  • I had the exact same problem, but haven't tested it on SP2 to see if it's an SP3-unique bug.  I resolved the issue by configuring everything except the Prevent Internet Access feature, then using the web filtering in my Barracuda Web Filter to manage the addresses this machine could get to.  I thought Steady State did a great job of locking down the computer as a kiosk, other than this glitch.

     

    Saturday, December 13, 2008 6:54 AM
  • I am also having the same issue and came across this on the forums:

    http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3682231&SiteID=17

    I disabled all restrictions and logged into the kiosk account that I created. I noticed that in IE7, under Tools -> Internet options -> Connections -> LAN Settings, that the box for 'Automatically detect settings' was checked, rather than there being an entry in the proxy server field, as listed in the link I posted above. No matter what I do, I can't get the box for
    'Automatically detect settings' to stay unchecked. Not sure if this is the issue or not, but thought I'd post this. Thanks,

    Sean
    Friday, January 23, 2009 2:48 PM
  • Hi,

    You don't have the ISA Firewall Client or Microsoft Firewall Client Management installed, do you?  These both reconfigure IE's internet settings automatically.  If they're installed, disable their "automatically configure browser" option to solve the problem.

    Thanks,
    Rob Elmer
    Development Lead
    Windows SteadyState
    Saturday, January 24, 2009 7:55 PM
  • Hi Rob,
    Thanks for your response! No, we do not have either installed. I did attempt to lift all the restrictions on the kiosk account except for the 'Prevent IE from accessing web sites' and I kept the web site exceptions. When I logged into the kiosk account, I checked under Tools -> Internet options -> Connections and discovered that the 'Automatically detect settings' box was unchecked. The proxy server field was properly set, with nointernetaccess as the proxy name and port 80 selected. I could access the restricted sites with no problems while other sites were blocked, so I thought, excellent, it works. I went back into my admin account and placed all the restrictions back on. Logged back into the kiosk account and I could access only restricted sites. I repeated this several times on Friday and the restricted sites could be accessed with no problem. I came in this morning to check and see if IE7 would access these sites, and I was greeted with the "The page could not be found" message. Is there anything else I could try? It seems to me that perhaps the automatically detect settings box is getting checked, but I'm not sure why this would be.

    Sean
    Monday, January 26, 2009 2:49 PM
  • In Steady State's  "Feature Restrictions" of the account you want to configure you disable  (unhook) the feature "Prevent changes to Internet Explorer registry settings". Only then will the web addresses allowed or disallowed take effect. you can always enable the first setting again when all the internet restrictions are working the way you wanted.

    Sunday, February 1, 2009 12:27 PM