locked
Typing in Japanese in winpe RRS feed

  • Question

  • My issue is

    Customer is trying to work with the winpe

    He wants to use Japanese Characters when he inputs the information on the screen.

    So instead of entering in the User name : Mkuriel ( English ) he will input the Japanese Characters ( Sorry don’t know Japanese J  ) .

    i am using the dism commands to set ja-jp for the winpe

    /set-syslocale

    /set-userlocale

    /set-inputlocale

    /set-UIlang

    /Set-LayeredDriver:6

    /Gen-LangINI 

    i have added the LP to the winpe but still i can only type in English... any ideas ? 

    thanks in advance for your assistance.


    Mkuriel

    Monday, November 23, 2015 9:48 AM

Answers

  • Reading what you said you did tell me you did not read all the article.

    When you did the Dism /image:D:\winpe\mount /Get-Intl

    Do you see the additional language


    Also once in Winpe if you want to change the some of those setting to the one inside the winpe you need to use 

    wpeutil SetKeyboardLayout Jap:keyboard

    Read about this here: https://technet.microsoft.com/en-ca/library/cc765969(v=ws.10).aspx

    • Proposed as answer by jim-xu Wednesday, December 2, 2015 4:49 AM
    • Marked as answer by Bruce Wooding Wednesday, December 2, 2015 10:35 PM
    Tuesday, November 24, 2015 1:32 PM

All replies

  • Follow this Technet article 

    https://technet.microsoft.com/en-us/library/dd744262(v=ws.10).aspx

    To change the kyeboard layout look at this one. A bit old but you will get the basic of it.

    http://www.windows-noob.com/forums/index.php?/topic/2348-guide-creating-a-bootimage-with-another-keyboard-layout-winpe-3/

    Another great guide here for you: https://sysadminblogger.wordpress.com/tag/custom-winpe-5/


    • Edited by Frederick Dicaire Monday, November 23, 2015 12:37 PM
    • Proposed as answer by jim-xu Tuesday, November 24, 2015 8:24 AM
    Monday, November 23, 2015 12:31 PM
  • i have read these articles but no luck ... 

    i am looking for another article to read ... 

    Japanese is very different.


    Mkuriel

    Tuesday, November 24, 2015 1:06 PM
  • Reading what you said you did tell me you did not read all the article.

    When you did the Dism /image:D:\winpe\mount /Get-Intl

    Do you see the additional language


    Also once in Winpe if you want to change the some of those setting to the one inside the winpe you need to use 

    wpeutil SetKeyboardLayout Jap:keyboard

    Read about this here: https://technet.microsoft.com/en-ca/library/cc765969(v=ws.10).aspx

    • Proposed as answer by jim-xu Wednesday, December 2, 2015 4:49 AM
    • Marked as answer by Bruce Wooding Wednesday, December 2, 2015 10:35 PM
    Tuesday, November 24, 2015 1:32 PM