none
Dynamic content from Internal ASP.net website RRS feed

  • Question

  • Hi group, first post and I come begging for help :) I have an Internal website (ASP application really) that I'm trying to make function through IAG2007. Most of the app/site works perfectly fine but when accessing dynamic content (ashx handler) I get a syntax error message when using it through the IAG, of course it's fine using it on my Intranet. Now, I'm a network analyst who's been tasked with "making it work" so some of these custom app configs are confusing to say the least. After reading through rafts of How to's and what nots  this that and the other thing I think I need to...allow..something..somewhere with either a custom ruleset or content type for this ashx handler or ? 

    /OCCMS/ is the website/app home and this is the error:

    Message: Syntax error
    Line: 317
    Char: 3
    Code: 0
    URI: https://XXXXXXXXXXX/whalecomab3d12123d/whalecom0/OCCMS/ajaxpro/core.ashx

    Any thoughts or help would be appreciated. I don't even know if I'm on the right track with the handler thing or not.

    Thanks guys
    Shawn
    Thursday, March 18, 2010 3:36 PM

Answers

  • Hi Shawn--

    I'm part of the Professional Services team at Celestix which does UAG, TMG deployments  | Training amongst many other things.  If you haven't already, please open a ticket.  We can update this thread once we get you an acceptable solution.

    Thanks!
    Dennis

    • Marked as answer by Erez Benari Wednesday, March 24, 2010 8:38 PM
    • Marked as answer by Erez Benari Wednesday, March 24, 2010 8:38 PM
    Tuesday, March 23, 2010 7:06 PM

All replies

  • Hello Shawn,

    I'm going to share with you some steps to try that go from Easy - Basic - Intermediate to finally expert level.

    Please let me know if the following resolves your issue or not.  If it doesn't, we will try the something else.


    1) IAG Configuration UI >> Select your application >> Application Properties >> Portal Link >> Check the box that says "Open in a New Window".

    Give this a try, we've seen issues where custom built .NET pages do not like to be inside a frame or shared with other pages.  I am hinting that it doesn’t like to be within the whale toolbar.

    Thank you
    Dennis

    • Marked as answer by Erez Benari Thursday, March 18, 2010 11:05 PM
    • Unmarked as answer by mshawn Monday, March 22, 2010 1:55 PM
    • Unmarked as answer by mshawn Monday, March 22, 2010 1:55 PM
    Thursday, March 18, 2010 8:31 PM
  • Hey Dennis, nope it's already opening in a seperate window. That error occurs when I try to open a search result inside the app, otherwise it works.

    Dennis, beside your name it says [Celestix], is that because you use or you work for Celestix cause my IAG is actually on a Celestix box as well. Now I do have a support contract with them. I just didn't think this was a support issue, it's not like it's broken I just can't figure out how to do something.

    Should I open a support request?

     

    Thanks

    Shawn

    Friday, March 19, 2010 1:10 PM
  • Hi Shawn--

    I'm part of the Professional Services team at Celestix which does UAG, TMG deployments  | Training amongst many other things.  If you haven't already, please open a ticket.  We can update this thread once we get you an acceptable solution.

    Thanks!
    Dennis

    • Marked as answer by Erez Benari Wednesday, March 24, 2010 8:38 PM
    • Marked as answer by Erez Benari Wednesday, March 24, 2010 8:38 PM
    Tuesday, March 23, 2010 7:06 PM