New projects stuck at 94% when publishing, error 23000(0x59D8) RRS feed

  • Question

  • Hi,

    I'm having issues with publishing new projects in Project 2010. When I create a new project, I can perfectly save it, but when publishing the project, it gets stuck on 94% and returns an error 23000(0x59D8).

    XML error:

    <?xml version="1.0" encoding="utf-16"?>
    <class name="Microsoft.Office.Project.Server.BusinessLayer.Queue.Message">
    <error id="23000" name="ProjectPublishFailure" uid="d44795f9-653f-40ff-9ae7-1f4db6d40b02" projectuid="9c9594bf-856d-486c-9c31-62b77472156a" messagetype="Microsoft.Office.Project.Server.BusinessLayer.QueueMsg.ConflictResolutionMessage" messageID="182" stage="" blocking="Block"/>
    <class name="Queue">
    <error id="26000" name="GeneralQueueJobFailed" uid="1baca117-89db-47d9-9417-653ca6bf36d5" JobUID="5d7ad652-2650-4b13-9fff-59c0412a658f" ComputerName="NTCW11" GroupType="ProjectPublish" MessageType="ConflictResolutionMessage" MessageId="182" Stage=""/>

    This only occurs for new projects.

    In the "Manage Queue Jobs", the Project Publish queue is in state "Failed and Blocking Correlation", with following error:

    ProjectPublishFailure (23000). Details: id='23000' name='ProjectPublishFailure' uid='c8a143b4-1f39-4bf3-bca6-2a66e3fdfef1' projectuid='9c9594bf-856d-486c-9c31-62b77472156a' messagetype='Microsoft.Office.Project.Server.BusinessLayer.QueueMsg.ConflictResolutionMessage' messageID='182' stage='' blocking='Block'. 
    GeneralQueueJobFailed (26000) - ProjectPublish.ConflictResolutionMessage. Details: id='26000' name='GeneralQueueJobFailed' uid='2cac74be-cdd9-4f62-8ee7-9b5007a7056e' JobUID='5d7ad652-2650-4b13-9fff-59c0412a658f' ComputerName='NTCW11' GroupType='ProjectPublish' MessageType='ConflictResolutionMessage' MessageId='182' Stage=''. For more details, check the ULS logs on machine NTCW11 for entries with JobUID 5d7ad652-2650-4b13-9fff-59c0412a658f. 

    I also can't find the project based on its Project UID in the database. This problem didn't occur before I was on vacation..

    Any help/suggestions?

    Tuesday, August 6, 2013 12:18 PM

All replies

  • What do you see in the ULS logs?

    Trying to remember when I've seen this before.  As I recall, we were having a memory leak at the same time, although the error message doesn't appear to be the same.

    I'd also check on corruption in the file or potentially the orphan baseline issue (search for Brian Smith's blog on the latter).  For potential corruption, do a save for sharing and then check the file back in.

    If you can't find the UID in the Reporting database, take a look at Draft and/or Published.  If the Publish job doesn't complete, it's probably not getting pushed into Reporting.

    Andrew Lavinsky [MVP] Blog: Twitter: @alavinsky

    Wednesday, August 7, 2013 2:41 AM
  • I see all kinds of things in the ULS logs, but I must say I'm not very familiar with them. I made a copy of the most recent entries that occurred when publishing a new project:

    Corruption doesn't seem like a problem, all new projects have this same issue.

    I did find the Project UID in the Draft database.

    Wednesday, August 7, 2013 7:10 AM
  • Hi,

    Your problem is almost similar to an old Project Server 2007 issue. Maybe the following post will help you further along.

    Hope it helps.

    With Kind Regards,

    Robin Kruithof

    Technical Consultant EPM

    • Proposed as answer by JGabo Monday, September 19, 2016 5:42 PM
    Wednesday, August 7, 2013 7:15 AM
  • Hi Robin,

    Seemingly similar, I think the issue I'm having is quite different. No trace of the same error message in the ULS logs, and nothing is noted about ResUids in the ULS logs.

    Wednesday, August 7, 2013 7:23 AM

  • This seems to be a Possible corruption due to restoration of a corrupt project plan, a possible SQL performance issue, possible corruption caused by different update level of server and clients.

    Resolution Plan:

    1-     Backup your project server four databases
    2-     Save the affected project plan file locally
    3-     Delete the affected project plan from Published DB ONLY  via Delete Enterprise Objects in PWA
    4-     Re-publish it back to server using the Draft version inside project Professional 2010 (the local saved copy)

    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.

    Thursday, August 22, 2013 9:41 PM
  • Ruben says this is happening for all new projects Dinesh - so your steps above may not be useful in this case. 

    Ruben, are all new projects created from the same template? If you create plans from another template or just blank ones do they publish OK?

    I'm seeing a key not found exception in the ULS log you shared regarding a custom field.  Have you modified or deleted any fields lately?  Perhaps it is trying to find a custom field that no longer exists.  Can you re-open the saved plans?  Are they really getting created ok?

    I'd suggest opening a support incident if you are still having issues - we may need to take a look deeper at your system.

    Best regards,


    Blog | Facebook | Twitter | Posting is provided "AS IS" with no warranties, and confers no rights.
    Project Server TechCenter | Project Developer Center | Project Server Help | Project Product Page

    Friday, August 23, 2013 9:59 PM
  • Did you assign any resources to a summary task?

    If you did, remove all assigned resources from summary tasks and sava as project. Then publish the project again. It sould be fine now.

    Tuesday, October 15, 2013 7:10 PM
  • Buenos dias

    El erro se presenta  por lo siguiente:
    No puede dejar actividades hijas  vencidas sin recursos asociados, Una ves coloque los recursos a las tareas intente publicar de nuevo  Buena suerte ¡¡ att : Cristian C Ruiz  (de  Colombia )

    Thursday, February 6, 2014 4:15 PM
  • En mi caso el error 23000(0x59D8) presentaba debido a que no se podia sincronizar un recurso local de project profesional con project server, por lo cual se debe reemplazar el recurso local por un recurso de empresa (de project server) desde la opcion de CREAR EQUIPO DESDE LA EMPRESA. luego de esto pude sincronizar el proyecto sin problema y se creo el sitio de Sharepoint


    Andres Ramirez Jaramillo.

    Tuesday, February 10, 2015 4:41 PM
  • Good afternoon,

    I ran into the same problem, I have the same message when I publish the project. Could you write how the problem was solved?

    Best Regards,

    Yanis Suleimanov

    Friday, August 28, 2015 2:06 PM
  • Run the SharePoint Products Configuration Wizard and see if it completes successfully. This often will fix and weird issues with Project Server.   I have found that sometimes a windows patch may have an effect on Project server and the Configuration Wizard, fixes it.

    Michael Wharton, MVP, MBA, PMP, MCT, MCTS, MCSD, MCSE+I, MCDBA
    Blog contains my field notes and SQL queries

    Thursday, September 3, 2015 4:07 AM
  • Hello,

    I know this is a very old thread but just incase there are some stuck in this error, I will post how mine got sorted.

    I had the same issue but where there are times it throws error during the Save and Publish event of a project. What I would normally do if the issue happens during Save is that I would proceed on Publishing my project. Most times it would allow me to but sometimes it throws an error. What I would do next is to save again my project. By this time there will be no error in Saving as well as Publishing the project.

    If the advise above does not fix the error, the blog below explains this scenario and gives solution to this error. Hope this help you guys.

    Cheers :)

    Thanks, aproclou

    Friday, April 8, 2016 7:30 AM
  • In my environment was this issue caused by resource throothling, (in documet library on project workspace was 14000items) i increased limit to 20000items and this undocumented product feature didn't crashed.
    Thursday, June 30, 2016 8:20 PM