none
Deployment fails with Partitioning error when trying to configure multiple NICs

    Question

  • I'm struggling to get this working with MST 2013 Update 1

    Ive configured ZTIGather.xml and the MDT Database and added the necessary changes to allow for OSDAdpater1<blah>

    All goes well, I can enter the necessary configuration in the console

    But, when I boot and start to run the TS, it bombs out with:

    FAILURE (7813): False: Verify there are partitions defined in this task sequence step

    Looking at BDD.log I see this:

    Property OSDDISKINDEX is now = Test LAN
    Obtained OSDDISKINDEX value from SQL:  OSDDISKINDEX = Test LAN
    Property OSDPARTITIONS is now = 00:0C:29:A9:B0:92
    Obtained OSDPARTITIONS value from SQL:  OSDPARTITIONS = 00:0C:29:A9:B0:92
    Property OSDPARTITIONS0TYPE is now = FALSE
    Obtained OSDPARTITIONS0TYPE value from SQL:  OSDPARTITIONS0TYPE = FALSE
    Property OSDPARTITIONS0FILESYSTEM is now = 10.0.0.5
    Obtained OSDPARTITIONS0FILESYSTEM value from SQL:  OSDPARTITIONS0FILESYSTEM = 10.0.0.5
    Property OSDPARTITIONS0BOOTABLE is now = 255.255.255.0	
    Obtained OSDPARTITIONS0BOOTABLE value from SQL:  OSDPARTITIONS0BOOTABLE = 255.255.255.0

    This cleary isn't right and should be being set as OSDAdapter1...

    Stumped...


    Regards Craig Wilson


    Saturday, October 24, 2015 9:16 PM

Answers

  • I *think* I've resolved the issue

    All the information on the web tells us to alter the [mdt].[dbo].[settings] Table and the ZTIGather.xml file as I did above

    I did a little digging around the share and the database.

    There is also another table - [mdt].[dbo].[Description] - This controls the order in which stuff is displayed in the Database view of the Deployment Workbench - I updated this table with the new Adapter settings. but this alone made no difference.

    After a LOT of Googling and hair pulling, I stumbled across this TN article (http://blogs.technet.com/b/mmodin/archive/2010/02/03/how-to-extend-the-mdt-2010-database-with-custom-settings.aspx) which mentions a set of Stored Procedures.. 

    EXECUTE sp_refreshview '[dbo].[ComputerSettings]'
    EXECUTE sp_refreshview '[dbo].[LocationSettings]'
    EXECUTE sp_refreshview '[dbo].[MakeModelSettings]'
    EXECUTE sp_refreshview '[dbo].[RoleSettings]'
    Once I ran these SP's - everything started to work!

    (To my knowledge this TN article is the only article that refers to them!)


    Regards Craig Wilson


    Tuesday, October 27, 2015 6:55 AM

All replies

  • This is really strange.  File a connect bug, with lots of detail and your mdt logs attached.

    Logs are very important. If you are unsure how to post logs or where to find them then reference https://keithga.wordpress.com/2014/10/24/video-mdt-2013-log-files-basics-bdd-log-and-smsts-log/ Also if you have made customizations please mention them when asking for help.

    Tuesday, October 27, 2015 12:46 AM
    Moderator
  • I *think* I've resolved the issue

    All the information on the web tells us to alter the [mdt].[dbo].[settings] Table and the ZTIGather.xml file as I did above

    I did a little digging around the share and the database.

    There is also another table - [mdt].[dbo].[Description] - This controls the order in which stuff is displayed in the Database view of the Deployment Workbench - I updated this table with the new Adapter settings. but this alone made no difference.

    After a LOT of Googling and hair pulling, I stumbled across this TN article (http://blogs.technet.com/b/mmodin/archive/2010/02/03/how-to-extend-the-mdt-2010-database-with-custom-settings.aspx) which mentions a set of Stored Procedures.. 

    EXECUTE sp_refreshview '[dbo].[ComputerSettings]'
    EXECUTE sp_refreshview '[dbo].[LocationSettings]'
    EXECUTE sp_refreshview '[dbo].[MakeModelSettings]'
    EXECUTE sp_refreshview '[dbo].[RoleSettings]'
    Once I ran these SP's - everything started to work!

    (To my knowledge this TN article is the only article that refers to them!)


    Regards Craig Wilson


    Tuesday, October 27, 2015 6:55 AM