locked
MsiInstaller Event 1008 when trying to install 3DS Max 2011 on Domain connected Windows 7 x64 machine RRS feed

  • Question

  • When I run setup for 3DS Max 2011 on my Windows 7 x64 machine when it's connected to my domain, the program starts to initialise, but then comes up with the following message:

    "This installation is forbidden by system policy. Contact your system administrator. #1"

    followed by

    "Fatal error during installation."

    At which point setup.exe bombs out. In the Application Log, I get this message:

    "The installation of C:\Users\username\AppData\Local\Temp\_random.tmp\SetupRes\eval.msi is not permitted due to an error in software restriction policy processing. The object cannot be trusted"

    Source: MsiInstaller  Event ID: 1008

    When I run this on a machine before adding it to the domain it works ok, so I know it's a policy or security setting of some sort, but I can't see how. We use Applocker policies which have been set to allow Admins to run all Windows Installer Files, Executables and Scripts on any Path. I've unlinked virtually all of the policies without any success in finding the problem. The Applocker event log doesn't show any errors to suggest it's blocking the program.

    Any help would be very gratefully received.

    Tuesday, October 26, 2010 10:44 AM

Answers

  • Hi, I’m not ensure it will fix your issue,  you can just try it and see. Or you could ask Windows Server Forum first:

     

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

     

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.  Thank you for your understanding.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Wednesday, November 3, 2010 2:27 AM
    Thursday, October 28, 2010 8:53 AM

All replies

  • Hi,

    As you said it works well before add it to domain, it seems some policies have been set to prevent installing software on PC. Please check if there are GPO settings on Windows Server. Or you can ask Windows Server Forum for further help:

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

    Furthermore,  you can try these steps below:

    1. Start -> Control Panel
    2. Open Administrative Tools
    3. Open Local Security Settings
    4. Click Software Restriction Policies a. If no software restrictions are defined, right click the Software Restriction Policies node and select New Software Restriction Policy
    5. Double click Enforcement
    6. Select "All users except local administrators"
    7. Click OK
    8. Reboot the machine or run gpupdate /force

     

    Also try installing the hotfix on server:

     

    http://support.microsoft.com/kb/925336


    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 28, 2010 6:29 AM
  • Hi Leo,

    Thanks for your reply. We do have Applocker policies set to block installations, but Administrators are exempt from this and are set to be allowed to run any file. We have tried the suggestion you made before, but from the Group Policy side. I tried it on the Local Policies as suggested, but unfortunately, I still get the same error.

    The hotfixes you've pointed to are for XP and Server 2003, do you know if they'd have the desired effect on Windows 7 or should I just try it and see?

    Cheers

    Neil

    Thursday, October 28, 2010 7:54 AM
  • Hi, I’m not ensure it will fix your issue,  you can just try it and see. Or you could ask Windows Server Forum first:

     

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

     

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.  Thank you for your understanding.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Wednesday, November 3, 2010 2:27 AM
    Thursday, October 28, 2010 8:53 AM