none
Cannot install UAG SP2 – Error 0xC00403A6 RRS feed

  • Question

  • This is a standalone workgroup UAG server.  All updates have been applied according to Technet articles.

    We are running the UAG SP2 update from an elevated command prompt using the following syntax:

    msiexec.exe /p UAG-KB2710791-v4.0.2095.10000-ENU.msp /l*vx ExtraVerbose.log

    The UAG SP2 update appears to be failing at the following point:

    UAG CA (Info): Info: Firing ProgressChanged event: Step: 15%, Description: 'Loading configuration from storage.'.
    MSI (s) (2C!F0) [11:07:41:140]: Closing MSIHANDLE (341) of type 790531 for thread 2544
    MSI (s) (2C!F0) [11:07:56:194]: Creating MSIHANDLE (342) of type 790531 for thread 2544
    UAG CA (Info): Info: PersistanceGateway.LoadConfigurationFromStorage -> Enter.
    MSI (s) (2C!F0) [11:07:56:209]: Closing MSIHANDLE (342) of type 790531 for thread 2544
    MSI (s) (2C!F0) [11:08:00:874]: Creating MSIHANDLE (343) of type 790531 for thread 2544
    UAG CA (Info): Error: Caught error (will rethrow after rollback): System.Runtime.InteropServices.COMException (0xC00403A6): Exception from HRESULT: 0xC00403A6
       at Microsoft.Isa.Interop.FPCClass.GetContainingArray()
       at Microsoft.UAG.Transformer.Core.PersistanceGateway.LoadConfigurationFromStorage()
       at Microsoft.UAG.Transformer.Core.SchemaConversionRuntime.Run()
    MSI (s) (2C!F0) [11:08:00:874]: Closing MSIHANDLE (343) of type 790531 for thread 2544
    MSI (s) (2C!F0) [11:08:00:874]: Creating MSIHANDLE (344) of type 790531 for thread 2544
    UAG CA (Info): Info: Firing ProgressChanged event: Step: 0%, Description: 'Conversion aborted due to error, Rolling back.'.
    MSI (s) (2C!F0) [11:08:00:874]: Closing MSIHANDLE (344) of type 790531 for thread 2544
    MSI (s) (2C!F0) [11:08:00:874]: Creating MSIHANDLE (345) of type 790531 for thread 2544
    UAG CA (Info): Info: Rolling-back manually.

    According to the TMG error table, Error 0xC00403A6 means

    E_FPC_NOT_CONNECTED_TO_ENTERPRISE FPC_ERR(0x3A6) 0xC00403A6 The property or method <Name> is not supported when the Forefront TMG computer is not connected to a Configuration Storage server.

    We have checked the configuration storage server status in TMG, looked for alerts or events and used LDP to test the connection to the CSS and all looks perfect.

    What else should we be looking for?

    Thanks;

    Don

    Friday, November 30, 2012 2:34 PM

All replies

  • I found it's quite complicated as well.

    First after upgraded to UAG SP2, all my previous settings were gone.  Couldn't import from backup, it said version's wrong.

    Manually rolled back, all settings were back, manually activated as told in other online forum, upgraded again, same, settings disappeared.

    Downgraded again, back, upgrade, failed, ended prematurely.  So far up and down several times, no idea.

    Will call MS next week...


    • Edited by Anonymos99 Friday, December 7, 2012 9:39 PM
    Friday, December 7, 2012 9:38 PM
  • Did you find a solution to this problem? Facing the same issue on a singel uag installation.
    Thursday, April 25, 2013 3:32 PM
  • In our case this was a NIC teaming problem.  The error translated as:

    D:\Tools\Err>err 0xC00403A6
    # as an HRESULT: Severity: FAILURE (1), Facility: 0x4, Code 0x3a6
    # for hex 0x3a6 / decimal 934 :
      ERROR_MAX_WAN_INTERFACE_LIMIT                                 mprerror.h
    # 1 matches found for "0xC00403A6"

    If you are doing NIC Teaming you should look at that. 

    Don

    Thursday, April 25, 2013 3:41 PM