none
After 12-2017 Cumulative Update: WScript Error Line 6, Char 5 800C005 msxml3.dll The system cannot locate the resource specified RRS feed

  • General discussion

  • Early Dec 25th, at the recommendation of askwoody.com, I fully updated my Win 10 Pro 10.0.15063 laptop.

    Later that day I noticed, when running a simple .vbs script, it failed with the above Windows Script Host error. Searched the internet and tried Safe Mode, running sfc /scannow and full virus scan -- no problems found but error persists.  Everything  else works as expected, however I rarely use scripts .. so really don't know if an app or a background task is failing.

    Did a full restore from a 3-day old backup --- now working again.

    Disabled VPN, antivirus, & firewall, stopped all/most user apps then fully updated again. Didn't rush the update, allowed system to settle before rebooting, or restarting/logging in, etc (Used to have issues with an old/Win7 after updates) 

    Working now ...... Created a task to run this .vbs every hour. Started out fine, but after ~8 hours -- FAILS w/same error! Of course, rebooting, safe mode, etc, etc again don't help. The following morning, problem remains.

    Did a full restore again from the same (now 5-day old) backup ----- and now it's working again.

    Does anyone know what in the world is going on here? I've never trusted Windows Updates, but this is the first time it's bitten me after being so cautious and waiting for the dust to settle.

    GetExternalIP.vbs

    wscript.echo WAN_IP()
    function WAN_IP()
     set obj = createobject("Microsoft.XMLHTTP")
     call obj.open("get", "http://ifconfig.co/ip", false)
     obj.send()
     strresponse = obj.responsetext
     set obj = nothing
     if strresponse <> "" then
       strIP = strresponse
     else
       strIP = "Unavailable"
     end if
     WAN_IP = trim(strIP)
    end function
    

    Sunday, December 31, 2017 3:04 AM

All replies

  • Unfortunately this is not a break/fix forum. In any case we don't recommend WSH scripts but would instead recommend PowerShell, particularly on Windows 10.

    -- Bill Stewart [Bill_Stewart]

    Sunday, December 31, 2017 5:41 AM
    Moderator
  • Questions like "I can't get this script to work that I've copied below, and here is the error I'm having" are welcome.

    Posting Guidelines

    Monday, January 1, 2018 5:46 PM
  • Questions like "I can't get this script to work that I've copied below, and here is the error I'm having" are welcome.

    Posting Guidelines


    That does not include system errors and system failures.  It is in direct reference to a script.  Read the post again.

    \_(ツ)_/

    Monday, January 1, 2018 6:15 PM
  • Read the posting guidelines again.
    Tuesday, January 2, 2018 1:55 AM
  • The issue is not scripting because the script works until after an update occurs, then the script stops working. That is known informally as "break/fix." We can't do anything to the syntax of the script to make it work because that isn't the problem. There's nothing we can do about that in this forum unfortunately. We would recommend not using that component and switch to PowerShell instead, particularly on Windows 10 (as already noted).


    -- Bill Stewart [Bill_Stewart]

    Tuesday, January 2, 2018 6:23 PM
    Moderator