locked
Removing left navigation pane issues RRS feed

  • Question

  • Hi,

    I'm trying to remove the left navigation pane from my master page and I'm having a bit of difficulty.

    Firstly I tried just deleting the whole pane but when I went to my site the page wouldn't load and I had an "unkown error" displayed

    Then I tried hiding the left pane by adding this line:

    <style>.ms-navframe{ display:none; }</style>

    This worked for my home page but when I go to any other page the left panel is still there. Should changes to the master page not effect all pages on the site?

    I opened the code of one of the pages that still has the panel and the MasterPageFile specified is not my new one, when I try changing it to my new one a pop up asks to match the content regions from my current master page to my new one. I don't really know what I'm ment to do here but I went through each one and if it didn't have a match I set it to "none". Once I did this the left navigation panel is still there.

    Anyone know where I'm going wrong or a better way to do this?

    Thanks
    Claire

    Wednesday, February 9, 2011 10:24 AM

Answers

  • Hi everyone, thanks for your help. The master page has definitly been published as the other changes I've made to it are on all the pages, just not the left pane. Christopher & Thomas, thanks for your suggestions - I've tried that but it didn't work.

    In the end I discussed it with the team I'm doing the site for and they now seem happy to leave the quick launch in it's default state so this isn't something I need to acheive anymore, frustrating that I spent so much time on it never to get a solution but sure that's how it goes sometimes!

    Thanks for all your time & help

    Claire

    Wednesday, February 16, 2011 9:23 AM

All replies

  • Open master page in SharePoint Designer, find the controls which render the left navigation and hide it.
    w: http://www.worldofsharepoint.com | t: @sharesandip
    • Proposed as answer by jmck23 Monday, April 7, 2014 5:59 PM
    Wednesday, February 9, 2011 10:38 AM
  • Thanks Sandip, I just tried this and it's the same thing - they're hidden on the default page but when I try a another page on the same site the panel is back again.
    Wednesday, February 9, 2011 10:53 AM
  • Hi,

    If you want do this for across the site then you have to make this changes in your master page.

    Open your site in designer-->_catalog-->check out your master page--->find below content place holder and add Visible=false

    <asp:ContentPlaceHolder id="PlaceHolderLeftNavBar" runat="server" Visible="false">

    Hope it could help


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Wednesday, February 9, 2011 11:04 AM
    Moderator
  • Thanks Hemandra, it is the master page that I was making these changes to. If hide the PlaceHolderLeftNavBar it's hidden from my site default page but if I go to any list page or document library it's there again. In Sharepoint designer I've right clicked and selected "Set as default master page", is there something else I need to do also to get it to be used accross the site?

    Thanks

    Wednesday, February 9, 2011 11:09 AM
  • I've just realised that other changes I've made to the master page are showing on all the site's pages (i.e. hiding the search box). I guess that means it's a problem directly relating to the left panel has opposed to the site pages not using the correct masterpage
    Wednesday, February 9, 2011 11:16 AM
  • Hi,

    Have you approved and published your master page? Once you made the changes then right click on your master page -->Click "Check-In"-->Publish it.

    After this Go to your site-->Site Settings-->Click "Master Pages and pagelayout" and approved it.

    >list page or document library it's there again

    Once you set the visibility = false then you won't be able to see any link in left pane. So how you are going to your list page and library?

    Let us know your result


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Wednesday, February 9, 2011 11:22 AM
    Moderator
  • Once changes done in masterpage, have you published that? or otherwise still it remains as draft version.


    Thanks & Regards, Neerubee
    Wednesday, February 9, 2011 11:24 AM
  • I think you also have to select "Set as custom master page" in SPDesigner for those list form pages.

    (I believe they are the same 2 masterspages as if you go to changesitemaster.aspx that are called Site Master and System Master.)

    Either that or the pages you are looking at are using the application.master.

     

    Wednesday, February 9, 2011 8:55 PM
  • Yes make sure you apply it as custom / default, see where that gets you. also sometimes when you hide the nav and go to edit the page - > web part properties the screen shrinks and its impossible to use. this can be fixed via CSS.

     


    -tom daly
    Wednesday, February 16, 2011 5:15 AM
  • Hi everyone, thanks for your help. The master page has definitly been published as the other changes I've made to it are on all the pages, just not the left pane. Christopher & Thomas, thanks for your suggestions - I've tried that but it didn't work.

    In the end I discussed it with the team I'm doing the site for and they now seem happy to leave the quick launch in it's default state so this isn't something I need to acheive anymore, frustrating that I spent so much time on it never to get a solution but sure that's how it goes sometimes!

    Thanks for all your time & help

    Claire

    Wednesday, February 16, 2011 9:23 AM
  • Sorry that didn't work for you, you could also try hidding the quick launch via CSS.

    Since your already in the masterpage you could link it to a custom css file. in that file have this

    #LeftNavigationAreaCell { display: none; }

    this will remove it, I would check to make sure you can still edit web part properties b/c i've noticed that sometimes the height on the page is messed up using that. In that case i add this to force the web part property toolbox to stay a set size.

    #MSOTlPn_Parts { height: 500px; }


    -tom daly
    Thursday, February 17, 2011 6:24 PM