locked
Upgrade Advisor Hangs RRS feed

  • Question


  •  I have been trying to load the latest RC. I have tried to run the Upgrade Advisor and it never stops scanning. I have let it scan while I went to work and it still is scanning. My machine easily meets the min req for the install and have no other issues than this. Any thoughs?
    Monday, September 11, 2006 11:53 PM

All replies

  • Im having the same exact problem....
    Sunday, October 8, 2006 10:35 PM
  • I'm having exactly the same problem and Vista is now final. I know the computer I tested is a little slow (perhaps too slow for Vista), but it shouldn't scan for hours.
    Friday, November 24, 2006 2:15 PM
  • I am having the same issue on a PC that easily should meet the specs for Vista.   The software scans for hours and never finishes.    Is there a bug with upgrade advisor?
    Thursday, January 4, 2007 12:55 PM
  • Microsoft has confirmed me about 1-2 weeks ago that the Vista Upgrade Advisor is still Beta software. (Vista itself is final.) My problem has been solved in the meantime. Just uninstall the Vista Upgrade Advisor and install the newest version from the homepage. Furthermore, try at an hour when it's unlikely that many users are online (at 4 A.M. or so), because Vista Upgrade Advisor updates itself before running and when the Server is busy this situation also might occur. Hope this helps.

    Eric

    Thursday, January 4, 2007 1:05 PM
  • Nothing seems to help.

    I have the same problem as the others. Advisor just keeps "scanning".

    Have tried uninstalling, rebooting, re-installing (from the Vista website), rescanning... ad nausium.

    Tried scanning at various times during the day or night with no change.

    This makes me VERY nervous about Vista and if it is going to give me this much problem.

    I have seven of my own computers to upgrade and twenty three customers with a total of forty seven computers. I REALLY hope this is not indicitive of Vista...

    Tuesday, January 30, 2007 2:35 AM
  • Hi Aart12,

     

    We have seen several reports of scanning not finishing. While it's working for the vast majority of people, these reports have shown several causes.

     

    The first step is to see how far VUA got into its scanning process.

    Please look in your temp directory for VUA temp files. Your temp directory is C:\Documents and Settings\ your alias \Local Settings\Temp

     

    Please remove these files & run VUA again. Let it run for up to 30 minutes & stop it.

     

    Look in your temp directory for files starting with VUA. You should have four or five files. Please post back with which files you have.

    Friday, February 2, 2007 2:16 AM
  • Hi all,

     

    Here is an update.

     

    VUA Download:

    http://www.microsoft.com/windows/products/windowsvista/buyorupgrade/upgradeadvisor.mspx

     

    1) Scan does not complete

    We think we have found a solution for this. We hope to have it on our website next week. If this prevents VUA from scanning indefinitely, it should also prevent problems with not being able to shutdown.

    (If you would like to try something sooner, you might consider installing IE7. I don't want to say that you need IE7. One of the many changes made by IE7 is the same change we are planning to make for VUA. Installing IE7 is something you could try as an experiment. If you do, please post back with your results.)

     

    2) Connectivity problems - proxy problems

    * Try setting the LAN Settings in Internet Explorer so nothing is selected, or to the "use a proxy" option. To specify a proxy, you will need to know the name or IP address of your proxy. VUA uses the settings from IE. If you are using another browser, this task needs to be done in IE.

    * VUA does detect proxies. It does not detect advanced proxy settings such as a proxy which uses password authentication. Advanced proxy settings such as this are usually only found in business environments.

    * If you have a local firewall on your PC, it's possible that it may be blocking VUA. Similarly, if you have a network firewall, it may be blocking VUA. These are issues with configuring your local/network firewall.

     

    3) Error:  "encountered an error while scanning your system"

    We do not yet have a fix for this.  We are still investigating.

     

    4) Cannot install VUA

    It may be due to problems with the subcomponents needed by VUA. You may want to try downloading these. Then you can install them separately and install VUA after.

     

    MSXML6

    http://www.microsoft.com/downloads/details.aspx?familyid=993c0bcf-3bcf-4009-be21-27e85e1857b1&displaylang=en

     

    .NET Framework 2.0

    http://www.microsoft.com/downloads/details.aspx?FamilyID=0856eacb-4362-4b0d-8edd-aab15c5e04f5&displaylang=en

     

    4) General troubleshooting has only changed a little:

    * Run VUA again later

    * Turn off antivirus/spyware programs

    * Download VUA again & install the new copy

    * We no longer think conflicts shown in Device Manager are causing problems with VUA.

    Friday, February 9, 2007 2:08 AM
  • I had the same problem with upgrade advisor stalling.

    decided to run install anyway, if stalled 3 times at various places [around entering key details.

    upon looking at the setupact.log file in the C:\$WINDOWS.~BT\Sources\Panther dir I noticed the following:

    2007-02-09 16:25:44, Info                  MIG    Incompatible app PowerDVD 6 (C:\Program Files\CyberLink DVD Solution\PowerDVD\PowerDVD.exe) is not blocking upgrade
    2007-02-09 16:25:44, Info                  MIG    CUpgradeCompatReport: App PowerDVD 6 (C:\Program Files\CyberLink DVD Solution\PowerDVD\PowerDVD.exe) is flagged: 16777217

    AND

    2007-02-09 16:25:47, Info                  MIG    Incompatible app Nero - Burning Rom (C:\Program Files\Ahead\Nero\nero.exe) is blocking upgrade
    2007-02-09 16:25:47, Info                  MIG    CUpgradeCompatReport: App Nero - Burning Rom (C:\Program Files\Ahead\Nero\nero.exe) is flagged: 16777216

    AND

    2007-02-09 16:25:48, Info                  MIG    Examining application: C:\Program Files\SoundTaxi\SoundTaxi.exe

    was the LAST entry in the log file which I guess it got stuck on??

    I uninstalled all 3 programs and a few other older things and then tried upgrade advisor again, it worked in a few seconds, and rather ironically pointed out that windows messenger might have minor compatibility issues!! I guess that is better than the last version I ran last week on another machine that reported Australia as being incompatible!

    I suggest somebody takes a look at these programs particularly Nero?

    Friday, February 9, 2007 7:33 AM
  • one important point.

    as said above ... whenever u run a upgrade advisor, please uninstall or atleast disable the following kinda of applications.

    1. cd/dvd burning applications

    2. firewall and other pop up or trojan blocking softwares

    3. may be disabling antivirus applications too.

    the above 3 are the first and foremost tip for running upgrade advisor.

    then comes the below points

    4. running a disk cleanup,

    5. cleaning the temp dirs

    6. and above all better to run a mscong and set the system to selective startup by removing the startup items and 3rd party services

    hope these 6 steps helps to resolve most of the upgrade advisor issues. !

    good luck

    Friday, February 9, 2007 10:59 AM
  • Hi ITechLegend,

     

    Here I'm adding some additional detail, such as the location of the temp directory and where to find Disk Cleanup. Plus, I'm giving alternates to mscong. I hope I have this right. I've cross-posted this to other threads with reference to you, "ITechLegend".

     

    Your suggestions for installing and running VUA:

     - Turn off CD/DVD burning software

     - Run Disk Cleanup  (Start-Programs-Accessories-System Tools-Disk Cleanup)

     - Clean the temp directory:  C:\Documents and Settings\ your alias \Local Settings\Temp

     - "mscong" I searched on it. My understanding is that it allows you to manage (disable/enable) programs which automatically run at startup and which continue to run in the background. I CANNOT recommend or endorse the app "mscong". I am not familiar with it. I do not know if it is safe to use.

    Perhaps these instructions will get at most of what mscong can do.

    * Look through your start menu to find apps that run in the background. Many/most of them will have entries in the start menu which allow you to disable that app.

    * (Advanced!) run services.msc to stop unneeded services  --  most apps that run in the background will show up here as a service.

    Friday, February 9, 2007 9:45 PM
  • I found that Sound Taxi was causing VUA not to finish. After removing Sound Taxi and rebooting VUA ran fine.
    Monday, February 12, 2007 3:50 PM
  • Hi jatho,

     

    You wrote that VUA would not complete scanning. And, that installing Vista failed. I agree that the last entry appears related. The log entry indicates that it started examining the app, but did not complete with determining its compatibility.

     

    I will forward your report that SoundTaxi may be causing VUA to fail to complete scanning. Andrew51 also reported in this thread that removing SoundTaxi allowed VUA to complete scanning.  

    Monday, February 12, 2007 7:57 PM
  • Hi all,

    Regarding the problem that VUA fails to complete scanning.

     

    VUA has been updated to fix this problem and the problem where you cannot shut down the computer.

     

    Please try this and post back if you still have problems.

    Monday, February 19, 2007 10:03 PM
  • Hi, Mike,

    I've been lurking for a week over this thread while quietly trying all the recommendations, to get VUA to run on one of my machines, a brand new VAIO running MCE v2002 SP2, lightly hacked to join a domain. No luck.

    WHERE does one get the version you referred to, in your 2-19 post? The version out at downloads.microsoft.com is still version 1.0, which hasn't worked for me.

    Steve Johnson
    Tuesday, February 20, 2007 6:57 PM
  • Hi Steve,

     

    Though we have not changed the version, the VUA download has been updated. Please download it and post back with your results.

    Tuesday, February 20, 2007 10:05 PM
  • OK, I uninstalled, and downloaded a fresh version at 2:30 pm Pacific Time, today, and installed.

    It ran for an hour and 15 minutes, and I killed it. No joy.

    Will the program do what it needs to do with Windows in Safe Mode, or does that deny it important information?

    Steve Johnson
    Wednesday, February 21, 2007 12:13 AM
  • Hi Steve,

    Please send me an e-mail. I'd like to work further with you offline.

    You can send mail to  Ba-mmoore@CmicrosoftD.com - this is a no spam address, just remove the capital letters for my address.
     (For others reading this, please post questions to the newsgroups. Only send mail to me if I request you to do so.)

    Thursday, February 22, 2007 2:43 AM
  • Hi Steve,

    Yes, I just tried it in Safe Mode. The only problem was that it could not properly determine if I could run Aero. Please try it and post back. And, as above, also send me mail.

    Thursday, February 22, 2007 2:47 AM
  • Hi, Mike,

    Sorry. I wimped out. I did a clean install, even formatted the drive. The moment is lost.

    Good luck.

    Steve J.
    Thursday, February 22, 2007 6:02 PM
  • Hi, Mike.

     

    In point number 2  paragraph 3 of the above reponse you state -

    * VUA does detect proxies. It does not detect advanced proxy settings such as a proxy which uses password authentication. Advanced proxy settings such as this are usually only found in business environments.

     

    What is the workaround for this?

     

    B

    Monday, June 4, 2007 6:35 PM