locked
Problems with WSUS RRS feed

  • Question

  • Hi All

    Up until recently, WSUS was working fine.

    The server hard disk was filled up with backups produced by a third party application.

    The backups were removed to free up the space taken

    Ever since the WSUS has not worked properly

    When it is opened, it shows the main status page as normal.  

    However, if you click on for example 'All Updates', nothing happens and it eventually displays a connection error.

    If you 'Copy Error to Clipboard' the following is shown:

    The WSUS administration console was unable to connect to the WSUS Server via the remote API.

    Verify that the Update Services service, IIS and SQL are running on the server. If the problem persists, try restarting IIS, SQL, and the Update Services Service.

    System.Net.WebException -- The operation has timed out

    Source
    System.Web.Services

    Stack Trace:
       at System.Web.Services.Protocols.WebClientProtocol.GetWebResponse(WebRequest request)
       at System.Web.Services.Protocols.HttpWebClientProtocol.GetWebResponse(WebRequest request)
       at Microsoft.UpdateServices.Internal.DatabaseAccess.ApiRemotingCompressionProxy.GetWebResponse(WebRequest webRequest)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
       at Microsoft.UpdateServices.Internal.ApiRemoting.ExecuteSPSearchUpdates(String updateScopeXml, String preferredCulture, Int32 publicationState)
       at Microsoft.UpdateServices.Internal.DatabaseAccess.AdminDataAccessProxy.ExecuteSPSearchUpdates(String updateScopeXml, String preferredCulture, ExtendedPublicationState publicationState)
       at Microsoft.UpdateServices.Internal.BaseApi.Update.SearchUpdates(UpdateScope searchScope, ExtendedPublicationState publicationState, UpdateServer updateServer)
       at Microsoft.UpdateServices.UI.AdminApiAccess.UpdateManager.GetUpdates(ExtendedUpdateScope filter)
       at Microsoft.UpdateServices.UI.AdminApiAccess.BulkUpdatePropertiesCache.GetAndCacheUpdates(ExtendedUpdateScope updateScope, ComputerTargetScope computerTargetScope)
       at Microsoft.UpdateServices.UI.SnapIn.Pages.UpdatesListPage.GetListRows()

    I've tried restarting the Update service, and IIS, and SQL with no result.

    Also tried this tool, but doesn't seem to have had an effect: wsus. codeplex. com /releases /view /17612

    Please can you offer any advice in resolving this issue

    Regards

    Amer

    Tuesday, July 7, 2015 12:48 PM

All replies

  • sounds like something other than just backups was removed.

    did you deploy WSUS using the free internal database option or a SQL server database?

    do you have a list of what was removed?

    Tuesday, July 7, 2015 2:45 PM
  • sounds like something other than just backups was removed.

    did you deploy WSUS using the free internal database option or a SQL server database?

    do you have a list of what was removed?

    Only a bunch of .bak files in one folder were deleted. Nothing else was touched.

    When the WSUS is started it shows the normal screen with all the elements populated. Apologies, but I can't yet post picrures.

    So it must be able to read the database? It's only when you try to drill down into the folder in the navigation tree that the error is displayed. I've tried re-indexing the database, but that made no difference. I'm in the process of running the clean-up wizard, but that's taking an absolute age!

    Regards

    Amer

    Wednesday, July 8, 2015 3:40 PM
  • Hi,

    Have you tried to use the server clean up wizard to remove the unused updates? If no, please try it. It works for me several times.

    Best Regards. 


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, August 10, 2015 8:22 AM