none
DPM 2010 - Cannot attach a x64 Windows 7 client - error 277 RRS feed

  • Question

  • Hello,

    We are trying DPM 2010, maybe for later use.

    DPM Server
    Windows Server 2008 r2 Enterprise

    When i want to install agents to x86 Windows 7 machines, everything works perfect, I can install an agent and attach the agent to the server.

    But when i want to install an agent to a x64 Windows 7 client, i get the following error:
    error 277 (Could not connect to the Service Control Manager on <ServerName>)

    Thanks in advance

    Friday, May 4, 2012 8:57 AM

All replies

  • Hmm, nobody replied yet.

    I've done some other things to hopefully correct the error, but no success.

    I've installed the x64 agent manually on the x64 W7 Client, that goes just fine.
    Then I ran SetDpmServer -DpmServerName "FQDN"
    Succesfully.

    After that I've tried to attach the client to the DPM server, same error as first post.


    After that I've tried to made an protection group, but it won't synchronise with the client.
    Error on server:

    The agent operation failed on GR006.xx.xx.local because DPM could not communicate with the DPM protection agent. The computer may be protected by another DPM server, or the protection agent may have been uninstalled on the protected computer.
    If GR006.xx.xx.local is a workgroup server, the password for the DPM user account could have been changed or may have expired.

    Error on client:

    DPM failed to communicate with the protection agent on gr006.xx.xx.local because access is denied

    I've searched for hours on the internet, no success.
    Just x64 clients don't work..

    Anyone?

    Tuesday, May 8, 2012 9:35 AM
  • I know your post is a few months old but I will respond anyway, just in case you have not found a solution yet. I fought this very problem. It depends on if you're having it with a bunch of machines or just the one. On a single machine you need to change DCOM settings. You can go to Admin Tools, component Services,then in the left column expand component services, expand computers, right click my computer then select properties then select the COM Security tab and Hit the top edit limits button. Select the everyone group ensure that remote access is checked, then go to the lower Edit Limits button and ensure that Remote Launch and Remote Activation boxes are checked.
    We had a large number of desktops so we put the DPM server object into the  local admins group, I think they had to do that on the DPM server as well if I remember correctly. I hope this helps.

    Greg

    Monday, July 30, 2012 3:20 PM
  • Yes, exactly the same with our system. I have even disabled firewalls on all computers using Group Policy, and still the same error. Only two computers (one with XP, another with 7 Enterprise x64) were successfully attached. On other computers I have installed agents, registered DPM server with dpmservername <fqdn>, and still the same errors when attempting to attach agents. What is causing these mystic errors?
    Thursday, October 4, 2012 8:03 AM