none
Deploying MSI to Core Server 2012R2 via GPO

    Question

  • I have a GPO that deploys an MSI and the first server it was tested on was a core Server2012R2. The GPO says there was no deployments in the Deployment Count under the settings tab. 

    Can you deploy software via group policy to a core server? 


    Charlie Newman

    Wednesday, November 04, 2015 3:02 PM

Answers

  • To my knowledge, the deployment count is showing you how many times you have re-deployed a MSI file. Each time you choose to re-deploy software this counter will increase with 1. So it will always be zero if you have never tried to redeploy application.
     
    >Can you deploy software via group policy to a core server
     
    I haven't tested this, but I think we should be able to deploy an MSI packages in combination with msiexec via group policy to it. How exactly you configured your GPO?
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Thursday, November 05, 2015 9:36 AM
    Moderator

All replies

  • To my knowledge, the deployment count is showing you how many times you have re-deployed a MSI file. Each time you choose to re-deploy software this counter will increase with 1. So it will always be zero if you have never tried to redeploy application.
     
    >Can you deploy software via group policy to a core server
     
    I haven't tested this, but I think we should be able to deploy an MSI packages in combination with msiexec via group policy to it. How exactly you configured your GPO?
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Thursday, November 05, 2015 9:36 AM
    Moderator
  • Have you checked on your Server Core server and see if the MSI got installed correctly?

    Server Core does include Gpresult command tool, so try to run it and see if the policy get applied correctly.

    Thursday, November 05, 2015 9:39 AM
  • Thanks for the understanding regarding the deploy count.

    The MSI appears to have installed in core mode. When the server was switched back to full mode, it acted like it was installing again. Perhaps the GUI part of the MSI was getting updated?


    Charlie Newman

    Thursday, November 05, 2015 2:41 PM
  • When the server was switched back to full mode, it acted like it was installing again. Perhaps the GUI part of the MSI was getting updated?

    I don't quite understand this, but as far as know, no updates made to the GUI part to server core.
    Friday, November 13, 2015 9:51 AM