locked
FSRM email notification not working RRS feed

  • Question

  • I am trying to setup an email notification for the File Server Resource Manager. I am sure that all input data is correct. Still when we send a test mail, FSRM give the following error:

    “Fail to send the test mail due the following error: cannot send the email due to an error. Check the application event log for more information”

    The Event Viewer shows the following error:

    Event id: 12306
    Source: SRMSVC
    A File Server Resource Manager email action could not be run.
    Error: IFsrmEmailExternal::SendMail, 0x8004531c, Failure sending mail:: Unable to read data from the transport connection: net_io_connectionclosed.

    Can someone tell me what is the problem?
    The only thing that I can think of is that our Default Frontend Connector listing on port 26.

    Configuration:
    windows server 2012
    exchange server 2013

    Thanks



    • Edited by M.K.Maduro Friday, June 10, 2016 5:49 PM
    Friday, June 10, 2016 2:48 PM

Answers

  • The reason that we use port 26 on our exchange is that we use eXchangePop3 to fetch our emails from our ISP. eXchangePop3 listing on port 25.

    In FSRM you cannot define the port number.

    Ok, then that would appear to be the issue then. 

    Blog:    Twitter:   

    • Proposed as answer by jim-xu Tuesday, June 14, 2016 6:35 AM
    • Marked as answer by jim-xu Tuesday, June 28, 2016 4:53 AM
    Monday, June 13, 2016 4:44 PM

All replies

  • I am trying to setup an email notification for the File Server Resource Manager. I am sure that all input data is correct. Still when we send a test mail, FSRM give the following error:

    “Fail to send the test mail due the following error: cannot send the email due to an error. Check the application event log for more information”

    The Event Viewer shows the following error:

    Event id: 12306
    Source: SRMSVC
    A File Server Resource Manager email action could not be run.
    Error: IFsrmEmailExternal::SendMail, 0x8004531c, Failure sending mail:: Unable to read data from the transport connection: net_io_connectionclosed.

    Can someone tell me what is the problem?
    The only thing that I can think of is that our Default Frontend Connector listing on port 26.

    Configuration:
    windows server 2012
    exchange server 2013

    Thanks



    Well the port 26 thing could be an issue yes. Why is it set to port 26?

    Can you define the port to send to on the FSRM side?


    Blog:    Twitter:   

    Saturday, June 11, 2016 12:52 PM
  • The reason that we use port 26 on our exchange is that we use eXchangePop3 to fetch our emails from our ISP. eXchangePop3 listing on port 25.

    In FSRM you cannot define the port number.

    Monday, June 13, 2016 3:52 PM
  • The reason that we use port 26 on our exchange is that we use eXchangePop3 to fetch our emails from our ISP. eXchangePop3 listing on port 25.

    In FSRM you cannot define the port number.

    Ok, then that would appear to be the issue then. 

    Blog:    Twitter:   

    • Proposed as answer by jim-xu Tuesday, June 14, 2016 6:35 AM
    • Marked as answer by jim-xu Tuesday, June 28, 2016 4:53 AM
    Monday, June 13, 2016 4:44 PM