Automatically executing the "Application Deployment Evaluation Cycle" (SendSchedule.exe question)


  • Trying to execute this action programmatically... Looks like you can use "SendSchedule.exe" to execute these types of actions, but I've tried them all, and they don't seem to do this action.

    I found in the "SendScheduleMessages.xml" there's a couple of ID's in there that don't seem to work, for me.

    {00000000-0000-0000-0000-000000000121} -- APPMAN_POLICY_ACTION_ID (This one works, but doesn't do the application deployment action)
    {00000000-0000-0000-0000-000000000122} -- APPMAN_USER_POLICY_ACTION_ID - Returns "Not found. Failed to send specified schedule."
    {00000000-0000-0000-0000-000000000123} -- APPMAN_GLOBAL_EVALUATION_ACTION_ID - Returns "Not found. Failed to send specified schedule."

    It seems like the 123 schedule is the one that I want. Why is it failing to send the schedule? It also doesn't show up when I run SendSchedules /L.

    Wednesday, October 10, 2012 6:38 PM

All replies

  • Hi,

    I just tested it on a client (uninstalled adobe reader from add/remove programs manually which is deployed as a required deployment for the Computer) used Sendschedule.exe {00000000-0000-0000-0000-000000000121} from the Configuration Manager 2012 Toolkit and it reinstalled Adobe Reader again just as it should so it seems to work fine for me.


    -- My System Center blog -- Twitter @ccmexec

    Wednesday, October 10, 2012 8:55 PM
  • Hm, I'm not sure why that doesn't appear to be the case for me. If I uninstall a required app, and run that task (even multiple times), nothing happens. As soon as I run the action in the CCM control panel, it reinstalls the required app.

    Any ideas...where to look to troubleshoot?  This is a lab environment, so I could just cross my fingers that it will work in prod when we get it built, but... right now I'm lost as to why it isn't working.

    Wednesday, October 10, 2012 9:01 PM
  • Hello,

    Did you ever get this working? I'm having the same problem with {00000000-0000-0000-0000-000000000121}

    Monday, August 11, 2014 11:30 AM
  • I found another way of doing it but it still doesn't necessarily seem to do the same thing as clicking the action through the UI, unfortunately.


    on error resume next
    dim oCPAppletMgr 'Control Applet manager object. 
    dim oClientAction 'Individual client action. 
    dim oClientActions 'A collection of client actions.
    set  oCPAppletMgr=CreateObject("CPApplet.CPAppletMgr")
    if err.number <> 0 then 
    end if
    set oClientActions=oCPAppletMgr.GetClientActions
    if err.number<>0 then
        set oCPAppletMgr=nothing
    end if
    For Each oClientAction In oClientActions
        'wscript.echo oClientAction.Name
        if oClientAction.Name = "Application Global Evaluation Task" then 
            'wscript.echo "Performing action " + oClientAction.Name 
        end if
    set oClientActions=nothing
    set oCPAppletMgr=nothing

    Monday, August 11, 2014 12:55 PM
  • Thanks Jason. I'll give it a go
    Monday, August 11, 2014 4:07 PM
  • Just in case anyone is looking (as I was) for an answer to this in 2017 CongfigMgr, schedule 121 does not detect applications deployed to User Collections. Only device collections it seems.

    You get this in the log if you use 121:

    * Evaluating Application policies for Machine  AppIntentEval 26/02/2018 12:04:58
    11764 (0x2DF4)
    But you DON'T get this:

    * Evaluating Application policies for S-1-5-21-583907252-1085031214-682003330-146952
    AppIntentEval 26/02/2018 12:09:12
    11484 (0x2CDC)

    The only way to get the user policy evaluation (S-1*) is to trigger the Application Deployment Evaluation Cycle from the Config Manager applet as the logged on user with the deployment you want.

    Monday, February 26, 2018 12:56 PM