none
DeployR Grid Stop event RRS feed

  • Question

  • Hi there.

    I'm using the RBroker framework from C# to call some R-function from an application, making discrete tasks. I have two identical configured DeployR-environments, running the exact same R-code. On the "good" server, for each request I receive a Grid Stop when my jobs are finished. (rBroker.shutdown). Here is a picture of the good server. 

    On the "bad server", I can't figure out why I'm not getting the Grid Stop event - even though the code is identical? It has the bad side-effect, that ressources aren't released and I'm hitting the grid limit on 100. See the bad server below. 

    The environments are build on the standard Azure R-Server image, running on SQL Server 2016 (R-server only)

    Any hints from any one on this behaviour?

    Monday, October 24, 2016 11:06 AM

Answers

  • Unfortunately, the server crashed and I had to restart the environment – after that, the Grid Stop event started to work again. That’s not great in a production environment …
    • Marked as answer by CarlNan Thursday, December 15, 2016 9:58 PM
    Monday, October 24, 2016 12:24 PM

All replies

  • Unfortunately, the server crashed and I had to restart the environment – after that, the Grid Stop event started to work again. That’s not great in a production environment …
    • Marked as answer by CarlNan Thursday, December 15, 2016 9:58 PM
    Monday, October 24, 2016 12:24 PM
  • Hi Anders,

    I would recommend you use the deployment functions of R Server 9.0 release. The setup experience, deployment experience and integration experience are greatly improved. You can find out the detail product documentation here: https://msdn.microsoft.com/en-us/microsoft-r/operationalize/about .

    Regards,

    Carl

    Friday, December 16, 2016 12:35 AM