locked
Cannot update a checkbox in Document Libraries RRS feed

  • Question

  • Hi,

    We have problem updating a column in a document library.  The type of this column is a checkbox.  I tryied to use the admin account to update (toggle) the value of this checkbox but the change just cannot be saved.

    Not sure what went wrong.  Anyone has any idea?

    Thanks,
    Arion

    Friday, October 14, 2011 6:02 AM

All replies

  • Not able to understand your question. Are you using custom forms and have you made changes to the field control?
    Shubham Goyal
    Friday, October 14, 2011 9:35 AM
  • Maybe you need to check out the item?
    Friday, October 14, 2011 12:48 PM
  • Sorry for being vague, here is a screenshot.  The columns that our users cannot modify are "ITS Reviewed", "ITSC Approved", and "Compliance / Regulation".  The type of these columns are Yes/No.

    Please let me know how should I fix it.

     

    Friday, October 14, 2011 6:39 PM
  • what steps are you taking to update the column value? Do you get any error in any of the steps?
    Shubham Goyal
    Friday, October 14, 2011 6:42 PM
  • Hi Shubham,

    I tried the follows to update the column:

    1. I check out the item, then Edit Properties and check the boxes and save. 
    2. I check it out and then Edit it in Datasheet, click on the check box then hit Enter key.  The check mark will be discard when I hit the Enter key.

    Thanks,
    Arion


    • Edited by Arion Chu Friday, October 14, 2011 7:18 PM can't update the column value on both #1 and #2
    Friday, October 14, 2011 7:08 PM
  • Are you checking the item back in after making the changes?

    Go through this article, it might help

    http://blog-sharepoint.blogspot.com/2010/08/metadata-not-saving-after-editing.html

     


    Shubham Goyal
    Friday, October 14, 2011 7:24 PM
  • Hi Arion Chu,

    are you getting any error while changing the column value? can you please check the log file (12 hive/logs) to get more information about this problem?

    Also please let us know which office version and IE version you are using.


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Wednesday, October 19, 2011 12:25 PM
    Moderator
  • Hi Hemendra,

    There is no erros in the logs.  I'm using Office 2010 and IE 8, OS is WinXP.  The same problem happens on Office 2010, IE 9 and Win7.

    I also tried to Edit in Datasheet--checked the box and then hit enter but the check mark got removed automatically at the moment I hit enter.

    Any idea?

    Thanks,
    Arion

    Wednesday, October 19, 2011 8:03 PM
  • Hi Arion,

    Maybe there is some problem with the edit form. Can you try doin this,

    Use SPD and create a new page inside this library and place a custom list form to replace the exsisting edit page.

    After replacing the edit page with the one newly created see if it works.


    Shubham Goyal
    Wednesday, October 19, 2011 8:35 PM
  • Hi,

    Sorry i am not able to reproduce your issue in my environment so can you do bit troubleshoot with in same site.

    just create one more library in same site and add two columns same datatype. Then upload document with metadata. Later on just try to edit the column value.

    Let us know whether it works in this library or not. If not, then we will go to next level.


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    Thursday, October 20, 2011 6:45 AM
    Moderator