locked
Blank screen when connecting to ATA Console second time RRS feed

  • Question

  • After install I am able to get to the configuration screen once. Any other connections from will simply have a blank screen sitting doing nothing. This also occurs if I close the first IE window after installation. Any ideas? I have made sure to have all the windows updates and preq KB's installed on the machine

    This is a Server 2012R2 machine. I have two IP's assigned to it and I am using self signed certs since I was trying to test out ATA before going into production.

    • Edited by Hunterprime Thursday, January 14, 2016 10:36 PM Added details
    Thursday, January 14, 2016 10:28 PM

All replies

  • Hi Hunterprime,

    did you checked:

    - IIS config

    - a reinstall

    - certificates

    - to open the webinterface on all IP addresses?

    Can you post the error messages? You can find it here: C:\Program Files\Microsoft Advanced Threat Analytics\Center\Logs\Microsoft.Tri.Center-Errors.log

    Regards

    Friday, January 15, 2016 7:46 AM
  • So I did a clean install and I can now open the console on the server its self but on any remote machines ASP crashes with this error. Any thoughts? I installed all the preqs

    Event code: 3005

    Event message: An unhandled exception has occurred.

    Event time: 1/21/2016 1:54:41 PM

    Event time (UTC): 1/21/2016 9:54:41 PM

    Event ID: 5dd5921e64fd4680a09229a373892788

    Event sequence: 46

    Event occurrence: 4

    Event detail code: 0

    Application information:

        Application domain: /LM/W3SVC/2/ROOT-1-130978866892601628

        Trust level: Full

        Application Virtual Path: /

        Application Path: C:\Program Files\Microsoft Advanced Threat Analytics\Center\Management\

        Machine name: SAWATAC01

    Process information:

        Process ID: 1332

        Process name: w3wp.exe

        Account name: NT AUTHORITY\SYSTEM

    Exception information:

        Exception type: HttpException

        Exception message: Server cannot append header after HTTP headers have been sent.

       at System.Web.HttpResponse.AppendHeader(String name, String value)

       at System.Web.HttpResponseWrapper.AppendHeader(String name, String value)

       at Microsoft.Owin.Host.SystemWeb.CallHeaders.AspNetResponseHeaders.Append(String key, String[] value, Int32 offset)

       at Microsoft.Owin.Host.SystemWeb.CallHeaders.AspNetResponseHeaders.Add(String key, String[] value)

       at Microsoft.Owin.HeaderDictionary.Add(String key, String[] value)

       at Microsoft.Tri.Management.Api.Service.Startup.<<Configuration>b__3_0>d.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContextStage.<RunApp>d__5.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Security.Infrastructure.AuthenticationMiddleware`1.<Invoke>d__0.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContextStage.<RunApp>d__5.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContext.<DoFinalWork>d__2.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.StageAsyncResult.End(IAsyncResult ar)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContext.EndFinalWork(IAsyncResult ar)

       at System.Web.HttpApplication.AsyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Request information:

        Request URL: https://10.11.112.110:443/login

        Request path: /login

        User host address: 10.11.112.122

        User: 

        Is authenticated: False

        Authentication Type: 

        Thread account name: NT AUTHORITY\SYSTEM

    Thread information:

        Thread ID: 9

        Thread account name: NT AUTHORITY\SYSTEM

        Is impersonating: False

        Stack trace:    at System.Web.HttpResponse.AppendHeader(String name, String value)

       at System.Web.HttpResponseWrapper.AppendHeader(String name, String value)

       at Microsoft.Owin.Host.SystemWeb.CallHeaders.AspNetResponseHeaders.Append(String key, String[] value, Int32 offset)

       at Microsoft.Owin.Host.SystemWeb.CallHeaders.AspNetResponseHeaders.Add(String key, String[] value)

       at Microsoft.Owin.HeaderDictionary.Add(String key, String[] value)

       at Microsoft.Tri.Management.Api.Service.Startup.<<Configuration>b__3_0>d.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContextStage.<RunApp>d__5.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Security.Infrastructure.AuthenticationMiddleware`1.<Invoke>d__0.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContextStage.<RunApp>d__5.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)

       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContext.<DoFinalWork>d__2.MoveNext()

    --- End of stack trace from previous location where exception was thrown ---

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.StageAsyncResult.End(IAsyncResult ar)

       at Microsoft.Owin.Host.SystemWeb.IntegratedPipeline.IntegratedPipelineContext.EndFinalWork(IAsyncResult ar)

       at System.Web.HttpApplication.AsyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

    Custom event details:

    Thursday, January 21, 2016 10:04 PM
  • Hi,

    which .NET is installed?

    Is the IIS console installed? If yes, check the AppPools.

    Regards

    Monday, January 25, 2016 8:04 AM
  • dotnet 4.6 with all updates is installed.

    I am not sure what you mean to check the app pools. This was a clean install that did not have IIS installed before installing ATA Console. All the app pools and webconfigs are the stock ones that it configures.

    Tuesday, February 2, 2016 11:07 PM
  • Anyone have any thoughts? This is completely blocking my ability to evaluate ATA for my company.
    Wednesday, February 24, 2016 9:03 PM
  • I had some new issues regarding ATA Website.

    I installed a new setup and also reinstalled is and for some reasons the "RewriteModule" from IIS was broken.

    If you are try to go into IIS > Sites > Microsoft ATA Console

    Is there a "URL Rewrite" present in the IIS section? If yes click on that to try if its working. If not you have to reinstall this module.

    Regards

    Thursday, February 25, 2016 7:27 AM
  • I had a similar issue when setting up the software. 

    Two things that I think might contribute, which helped me.. 

    - Have you got silverlight installed?

    - Do you have the IE enhanced security enabled ?

    I think it's ultimately the latter (IESC), once I'd checked these two, console appeared !

    Hope that helps anyone looking at this at a later time.

    Friday, June 3, 2016 8:25 AM