locked
Wsus client requires proxy authentication? not update with wsus? RRS feed

  • Question

  • Dear Support Team,

    I have wsus 3.0 installation in 2003 server and its downloading updates with sqid proxy.

    In some client i am facing the issue that it will not detect . also when i click on windows update it will asks the proxy authentication.

    I have do the wsus settings via registry on all client machine. KEY_LOCAL_MACHINE > SOFTWARE > Policies > Microsoft  > Windows > WindowsUpdate

    I have also troubleshooting like delete the sui id in registry, wuaclt /detectnow /repairenow.

    I have also disabled the proxy settings in IE . but still facing the same issue.

    Please find the attached screenshot.

    can you please help me regarding this.

    Thanks in Advance for your support.

    Bhautik Shah

    Monday, November 3, 2014 2:36 PM

Answers

  • Hi Mr.Lee,

    Proxy settings is disabled in this machine. but still same issue.

    I have run the command

    netsh winhttp import proxy source=ie and restarting the wsus service it will work,

    So my question is that if i am enable proxy settings again in client then problem will be come again or its working.

    • Proposed as answer by Steven_Lee0510 Monday, November 10, 2014 12:37 PM
    • Marked as answer by Steven_Lee0510 Wednesday, November 12, 2014 2:14 PM
    Tuesday, November 4, 2014 10:39 AM
  • I have wsus 3.0 installation in 2003 server and its downloading updates with sqid proxy.

    There's a long history of issues with WSUS and Squid. I don't recall the details; it's been several years since the question has come up. Is this a *new* installation? I'm curious that WSUS3/WS2003/Squid is only now an issue for you.

    You'll probably have to do a search in Google Groups to get the legacy content from the old Microsoft Newsgroups from 2005-2008 where these type of issues were discussed regarding WSUS on WS2003 and Squid.

    Ideal solution here is to NOT use the proxy server for WSUS.


    Lawrence Garvin, M.S., MCSA, MCITP:EA, MCDBA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2014)
    My MVP Profile: http://mvp.microsoft.com/en-us/mvp/Lawrence%20R%20Garvin-32101
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    • Proposed as answer by Steven_Lee0510 Monday, November 10, 2014 12:37 PM
    • Marked as answer by Steven_Lee0510 Wednesday, November 12, 2014 2:14 PM
    Saturday, November 8, 2014 2:58 PM

All replies

  • Hi Bhautik,

    Can this client access the WSUS without the proxy?

    If yes, please try to disable the proxy in the client.

    We can reset the proxy by using the command netsh winhttp reset proxy.

    To verify if the proxy is disabled, please run the command below,

    • netsh winhttp show proxy

    Make sure that "Direct access (no proxy server)." is shown.

    If issue persist, please reproduce the issue then post the windowsupdate.log here. It may give some hints.

    Best Regards.



    Steven Lee

    TechNet Community Support


    Tuesday, November 4, 2014 7:09 AM
  • Hi Mr.Lee,

    Proxy settings is disabled in this machine. but still same issue.

    I have run the command

    netsh winhttp import proxy source=ie and restarting the wsus service it will work,

    So my question is that if i am enable proxy settings again in client then problem will be come again or its working.

    • Proposed as answer by Steven_Lee0510 Monday, November 10, 2014 12:37 PM
    • Marked as answer by Steven_Lee0510 Wednesday, November 12, 2014 2:14 PM
    Tuesday, November 4, 2014 10:39 AM
  • I have wsus 3.0 installation in 2003 server and its downloading updates with sqid proxy.

    There's a long history of issues with WSUS and Squid. I don't recall the details; it's been several years since the question has come up. Is this a *new* installation? I'm curious that WSUS3/WS2003/Squid is only now an issue for you.

    You'll probably have to do a search in Google Groups to get the legacy content from the old Microsoft Newsgroups from 2005-2008 where these type of issues were discussed regarding WSUS on WS2003 and Squid.

    Ideal solution here is to NOT use the proxy server for WSUS.


    Lawrence Garvin, M.S., MCSA, MCITP:EA, MCDBA
    SolarWinds Head Geek
    Microsoft MVP - Software Packaging, Deployment & Servicing (2005-2014)
    My MVP Profile: http://mvp.microsoft.com/en-us/mvp/Lawrence%20R%20Garvin-32101
    http://www.solarwinds.com/gotmicrosoft
    The views expressed on this post are mine and do not necessarily reflect the views of SolarWinds.

    • Proposed as answer by Steven_Lee0510 Monday, November 10, 2014 12:37 PM
    • Marked as answer by Steven_Lee0510 Wednesday, November 12, 2014 2:14 PM
    Saturday, November 8, 2014 2:58 PM
  • This command solved my issue with our WSUS Client in Multiple VLans.  Thank you for your solution. I appreciate it a lot.

    netsh winhttp import proxy source=ie and restarting the wsus service

    Thursday, February 18, 2016 9:03 AM