none
How to remove language pack "English-United Kingdom:en-GB" from windows8.1 iso image

    Question

  • sir i have downloaded windows 8.1 and it has having default language English-united kingdom: en-GB

    then i have downloaded language pack English-united states: en-US  for windows 8.1

    and i have added to this language pack into windows 8.1 iso image using DISM successfully,
    also i have set default language: English-united states: en-US using DISM command:
    dism /get-intl
    dism /set-allintl:en-us

    now i want to remove previous language pack "English-united kingdom:en-GB"  using DISM, what is the command to remove this?
    • Edited by ssingh.pabla Saturday, February 15, 2014 12:21 PM
    Saturday, February 15, 2014 12:21 PM

Answers

  • Hi,

    Did you add the En-US language pack to this image? Please use the command below to add the language pack to image first.

    Dism /Image:C:\test\offline /ScratchDir:C:\Scratch /Add-Package /PackagePath:C:\packages\package1.cab


    Roger Lu
    TechNet Community Support

    Thursday, February 20, 2014 8:26 AM
    Moderator

All replies

  • this command does not work, error to open  C:\packages\package1.cab

    what is the exact name of language pack en-GB?

    Saturday, February 15, 2014 4:31 PM
  • thx sir, now i have successfully removed en-GB from image but when i install this image then still by default on first screen its shows:

    Language to install:  united kingdom

    time & currency format : united kingdom

    keyboard or input method: united kingdom

    while i have removed en-GB then why it shows these settings by defaults, how it can show below settings by default during installation, look at screen shot:

    Language to install:  united states

    time & currency format : united states

    keyboard or input method: united states




    Sunday, February 16, 2014 3:05 AM
  • Hi,

    Did you add the En-US language pack to this image? Please use the command below to add the language pack to image first.

    Dism /Image:C:\test\offline /ScratchDir:C:\Scratch /Add-Package /PackagePath:C:\packages\package1.cab


    Roger Lu
    TechNet Community Support

    Thursday, February 20, 2014 8:26 AM
    Moderator
  • My problem was that I could not SysPrep my vm for cloning. I have a package installed for English en-ZA which should be the only language installed using US keyboard layout.

    cd c:\Windows\system32\sysprep\

    c:\Windows\system32\sysprep> sysprep.exe /oobe /shutdown /generalize /mode:vm

    That caused error in Panther folder (c:\Windows\system32\sysprep\panther)

    Investigated log file in notepad

    Error                 SYSPRP Package Microsoft.LanguageExperiencePacken-gb_17134.3.5.0_neutral__8wekyb3d8bbwe was installed for a user, but not provisioned for all users. This package will not function properly in the sysprep image.

    This stopped SysPrep process.

    EVENTUALLY cobbled together this PowerShell script (run in as admin)

    #Get all application packages for all users

    Get-AppxPackage -allusers

    #once full name found, remove the package for all users

    #Remove-AppxPackage -Package "Microsoft.LanguageExperiencePacken-gb_17134.3.5.0_neutral__8wekyb3d8bbwe" -AllUsers

    This forced the removal of the offending experience package

    SysPrep ran after this

    Cheers

    Theo


    Theo Jacobs | Technical Team Lead / Senior Developer (MCT, MCP, MCPD, MCTS, MCAS) CulminIT | Durbanville | South Africa Phone (27) 21 914 8009 | tjacobs@culminit.co.za | theojacobs@workmail.co.za | http://www.culminit.co.za

    Thursday, June 21, 2018 6:08 PM